在线检测未来函数

飞狐机构筹码分析指标公式

来源:Internet,编辑:股旁网,2015-04-07

W: (SMA(WINNER(CLOSE),3,1) * 100),LINETHICK1,colorFF8080;
(SMA(WINNER(CLOSE),10,1) * 100),colorFF00;
PARTLINE(1,100),SHIFT6,colorFF8080;
PARTLINE(1,1),SHIFT6,colorFF8080;
PARTLINE(1,50),SHIFT6,colorFF8080;
W1:IF((W >= 10),W,0),LINETHICK0,colorFFFFFF;
W2:IF(((W >= 1) AND (W < 10)),(W * 10),0),LINETHICK0,colorFFFF;
W3:IF(((W >= 0.1) AND (W < 1)),(W * 100),0),LINETHICK0,colorFFFF00;
W4:IF(((W >= 0.01) AND (W < 0.1)),(W * 1000),0),LINETHICK0,colorFF80FF;
W5:IF(((W >= 0.001) AND (W < 0.01)),(W * 10000),0),LINETHICK0,colorFF0000;
W6:IF(((W >= 0.0001) AND (W < 0.001)),(W * 100000),0),LINETHICK0,colorFF00;
W7:IF(((W >= 0.00001) AND (W < 0.0001)),(W * 1000000),0),LINETHICK0,colorFF00FF;
STICKLINE(W1,0,W1,0.1,1),colorFFFFFF;
STICKLINE(W2,0,W2,3,1),colorFFFF;
STICKLINE(W3,0,W3,3,1),colorFFFF00;
STICKLINE(W4,0,W4,6,1),colorFF80FF;
STICKLINE(W5,0,W5,6,1),colorFF0000;
STICKLINE(W6,0,W6,6,1),colorFF00;
STICKLINE(W7,0,W7,6,1),colorFF00FF;
STICKLINE(((W * 100) = 0),0,36,8,1),colorFF;
PARTLINE(W1,W1),colorFFFFFF;
DRAWTEXT((BARSLAST((W1 = 0)) = 1),0,'1'),colorFFFFFF;
DRAWTEXT((BARSLAST((W2 = 0)) = 1),0,'2'),colorFFFF;
DRAWTEXT((BARSLAST((W3 = 0)) = 1),0,'3'),colorFFFF00;
DRAWTEXT((BARSLAST((W4 = 0)) = 1),0,'4'),colorFF80FF;
DRAWTEXT((BARSLAST((W5 = 0)) = 1),0,'5'),colorFF0000;
DRAWTEXT((BARSLAST((W6 = 0)) = 1),0,'6'),colorFF00;
DRAWTEXT((BARSLAST((W7 = 0)) = 1),0,'7'),colorFF00FF;
DRAWTEXT((BARSLAST(((W * 100) = 0)) = 1),0,'8'),colorFF;
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW));
A1:=DYNAINFO(6);
A2:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A3:=(VOL / WINNER(LOW));
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=((100 * (CLOSE - A5)) / (A4 - A5));
A7:=((A2 > 0) OR (A2 = 1));
A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));
A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));
A10:=(A8 AND A9);
A11:=IF(FILTER(A8,3),5,0);
A12:=IF((FILTER(A10,3) OR EE),10,0);
进场:STICKLINE(A11,0,5,5,0),colorFF7700;
加仓:STICKLINE(A12,0,15,5,0),colorFF00FF;
STICKLINE(A11,0,5,5,0),colorFF7700;
STICKLINE(A11,0,5,4.5,0),colorFF8800;
STICKLINE(A11,0,5,4,0),colorFF9900;
STICKLINE(A11,0,5,3.5,0),colorFFAA00;
STICKLINE(A11,0,5,3,0),colorFFBB00;
STICKLINE(A11,0,5,2.5,0),colorFFCC00;
STICKLINE(A11,0,5,2,0),colorFFDD00;
STICKLINE(A11,0,5,1,0),colorFFEE00;
STICKLINE(A12,0,15,4.5,0),color102099;
STICKLINE(A12,0,15,4,0),color1020AA;
STICKLINE(A12,0,15,3.5,0),color1020BB;
STICKLINE(A12,0,15,3,0),color1020CC;
STICKLINE(A12,0,15,2.5,0),color1020DD;
STICKLINE(A12,0,15,2,0),color1020EE;
STICKLINE(A12,0,15,1,0),color1020FF;
DRAWTEXT(A11,8,'进场'),colorFFFF00;
DRAWTEXT(A12,17,'加仓'),colorFFFF;

飞狐机构筹码分析指标公式

 

相关文章