在线检测未来函数

飞狐魔鬼线主图指标公式

来源:Internet,编辑:股旁网,2015-04-08

P1:=15;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,7,1),colorFF;
STICKLINE(OPEN>CLOSE,CLOSE,OPEN,7,0),colorFF00;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0,1),colorFF;
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0,1),colorFF;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,0,0),colorFF00;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,0,0),colorFF00;
魔鬼线:MA(CLOSE,P1),LINETHICK0,colorFF;
DRAWTEXT(REF(魔鬼线,1)>魔鬼线,魔鬼线,'*'),PXUP2,colorFF00;
DRAWTEXT(REF(魔鬼线,1)<魔鬼线,魔鬼线,'*'),PXUP2,colorFF;
一家精品:=EMA(EMA(EMA(CLOSE,2),2),2);
绝:MA(一家精品,13)*0.99,LINETHICK2,color6699;
胜:MA(一家精品,13)*0.999,LINETHICK2,colorDDDDDD;
司:6*HHV(绝,3)-5*绝,LINETHICK2,colorFFFF;
南:6*HHV(胜,4)-5*胜,LINETHICK2,colorFF0033;
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
M3:=MA(CLOSE,20);
M4:=MA(CLOSE,60);
M5:=MA(CLOSE,120);
PM3:=MA(CLOSE,30);
DRAWICON(M1>M2 AND M2>M3 AND M2>M4 AND M2>M5 AND M2>PM3 AND REF(M1,1)<M1 AND REF(M2,1)<M2 AND REF(M3,1)<M3 AND REF(PM3,1)<PM3,OPEN,12);
BB:=BARPOS=SYSPARAM(1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:='今天是:'+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日, '+WDAY[WD[P]+1];
EXPLAIN(BARPOS=P,STR1),colorFF;
EXPLAIN(1,STKLABEL+STKNAME+'\n所属板块:'+BLKNAME),colorFFFF80;
EXPLAIN(CLOSE>0,'〓 K 线形态分析 〓 '),colorFFFFFF;
★早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND (ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
★长十字:=CLOSE=OPEN AND HIGH/LOW>1.03;
★垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
★早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
★射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
★倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
★锤头:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
★吊颈:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
★穿头破脚:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1) OR REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
★乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
★曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
★身怀六甲:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND (ABS(CLOSE-OPEN))/CLOSE<0.005 AND MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
★十字胎:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND CLOSE<MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE>MIN(REF(CLOSE,1),REF(OPEN,1));
★平顶:=(ABS(HIGH-REF(HIGH,1)))/HIGH<0.001;
★平底:=(ABS(LOW-REF(LOW,1)))/LOW<0.001 AND (ABS(REF(LOW,1)-REF(LOW,2)))/REF(LOW,1)<=0.001;
★大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
★红三兵:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
★双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
★孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND CLOSE>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(CLOSE,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
★多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
★出水芙蓉:=(OPEN<EMA(CLOSE,20) OR OPEN<EMA(CLOSE,40) OR OPEN<EMA(CLOSE,60)) AND CLOSE>MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))) AND VOL/MA(VOL,30)>1.2 AND CLOSE/REF(CLOSE,1)>1.049;
★上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
★下跌三部曲:=REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4);
★跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
★三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
★光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
★光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
★分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
★长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
★长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
★十字星:=CLOSE=OPEN AND HIGH<>LOW;
★大阴烛:=OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018;
★好友反攻:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002 OR REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002;
★倾盆大雨:=REF(CLOSE,1)/REF(OPEN,1)>=1.03 AND OPEN<REF(CLOSE,1) AND OPEN>REF(OPEN,1) AND CLOSE<REF(OPEN,1);
EXPLAIN(★倾盆大雨,'★倾盆大雨★见顶信号;'),colorFFFF00;
EXPLAIN(★大阴烛,'★大阴烛★后市向淡,发生逆转;'),colorFFFF00;
EXPLAIN(★好友反攻,'★好友反攻★底部反转;'),colorFF;
EXPLAIN(★跳空缺口,'★跳空缺口★注意向上还是向下跳空;'),colorFFFFFF;
EXPLAIN(★光脚阴线,'★光脚阴线★下跌信号;'),colorFFFF00;
EXPLAIN(★光头阳线,'★光头阳线★后市看涨;'),colorFF;
EXPLAIN(★三只乌鸦,'★三只乌鸦★可能见顶回落;'),colorFFFF00;
EXPLAIN(★分离,'★分离★注意看涨分离和看跌分离;'),colorFFFFFF;
EXPLAIN(★长下影,'★长下影★持续下跌后出现,有可能止跌回升;在升势末期
出现,须多加留意;'),colorFF;
EXPLAIN(★长上影,'★长上影★表明行情上档压力沉重,升势受阻;'),colorFFFF00;
EXPLAIN(★下跌三部曲,'★下跌三部曲★下跌信号;'),colorFF;
EXPLAIN(★上升三部曲,'★上升三部曲★上涨信号;'),colorFFFF00;
EXPLAIN(★早晨之星,'★早晨之星★见底回升;'),colorFF;
EXPLAIN(★黄昏之星,'★黄昏之星★见顶回落;'),colorFFFF00;
EXPLAIN(★十字星,'★十字星★有转向意味,注意股价位置在顶部还是底部;
'),colorFFFFFF;
EXPLAIN(★长十字,'★长十字★注意在顶部还是底部;'),colorFFFFFF;
EXPLAIN(★垂死十字,'★垂死十字★下跌信号;'),colorFFFF00;
EXPLAIN(★早晨十字星,'★早晨十字星★上涨信号,见底回升;'),colorFF;
EXPLAIN(★黄昏十字星,'★黄昏十字星★下跌信号,见顶回落;'),colorFFFF00;
EXPLAIN(★射击之星,'★射击之星★可能见顶回落,可靠性低;'),colorFFFF00;
EXPLAIN(★倒转锤头,'★倒转锤头★可能见底回升;'),colorFF;
EXPLAIN(★锤头,'★锤头★可能见底回升,如有量配合,信号强烈;'),colorFF;
EXPLAIN(★吊颈,'★吊颈★上升行情中见顶回落,顶部出现,见顶信号;'),colorFFFF00;
EXPLAIN(★平顶,'★平顶★温和的反转;'),colorFFFF00;
EXPLAIN(★穿头破脚,'★穿头破脚★顶部出现,见顶回落信号;'),colorFFFF00;
EXPLAIN(★乌云盖顶,'★乌云盖顶★见顶回落信号;'),colorFFFF00;
EXPLAIN(★曙光初现,'★曙光初现★后市见底回升;'),colorFF;
EXPLAIN(★身怀六甲,'★身怀六甲★出现在底部,是见底回升信号;出现在顶部
,是见顶回落信号;'),colorFF;
EXPLAIN(★十字胎,'★十字胎★'),colorFF;
EXPLAIN(★平底,'★平底★温和的反转;'),colorFF;
EXPLAIN(★大阳烛,'★大阳烛★看涨;'),colorFF;
EXPLAIN(★红三兵,'★红三兵★每日收盘价上移,表示可能见底回升;'),colorFF;
EXPLAIN(★双飞乌鸦,'★双飞乌鸦★行情将见顶回落;'),colorFFFF00;
EXPLAIN(★孕育线,'★孕育线★注意股价位置;'),colorFFFFFF;
EXPLAIN(★多方炮,'★多方炮★在底部出现有上涨可能,在中间出现有可能是
上涨中继,顶部出现是复合见顶信号;'),colorFF;
EXPLAIN(★出水芙蓉,'★出水芙蓉★见底回升;'),colorFF;
A001:=CLOSE-REF(CLOSE,6);
A002:=MA(A001,6);
A003:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A004:=SMA(A003,3,1);
A005:=SMA(A004,3,1);
A006:=EMA(3*A004-2*A005,2);
A007:=(HIGH+LOW+CLOSE)/3;
A008:=(A007-MA(A007,14))/(0.015*AVEDEV(A007,14))/2;
A009:=(A008+EMA((-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))+100)/100,3)*200-100)/2;
A010:=A009-REF(A009,14);
A011:=A009-REF(A009,26);
A012:=(A009+A010+A011)/3;
KKM:=EMA(A012,4);
A013:=HHV(HIGH,34);
A014:=(2*CLOSE+HIGH+LOW)/4;
A015:=LLV(LOW,34);
A016:=EMA((A014-A015)/(A013-A015)*100,13);
A017:=EMA(0.667*REF(A016,1)+0.333*A016,2);
KKMD:=A016-A017>1 AND A016<30 AND A017<30;
KKML:=A016-A017<0 AND A016>80 AND A017>80 AND REF(A016-A017,1)>0;
KKMQ:=COUNT(A016-A017>0,2)=2;
KKAL:=A016-A017<0;
生命线:=MA(CLOSE,20);
取舍线:=MA(CLOSE,10);
EXPLAINICON(KKMD,4);
EXPLAINICON(KKAL,1);
EXPLAIN(KKMD,'最佳买入时机');
EXPLAIN(KKML,'最佳卖出时机');
EXPLAIN(KKMQ,'持仓区');
EXPLAIN(KKAL,'空仓区');
EXPLAIN(CLOSE/REF(CLOSE,1)>INDEXC/REF(INDEXC,1),'该股强于大盘');
EXPLAIN(CLOSE/REF(CLOSE,1),'该股强于大盘');
EXPLAIN(CROSS(MA(CLOSE,5),MA(CLOSE,10)),'可出手');
EXPLAIN(CROSS(MA(CLOSE,10),MA(CLOSE,5)),'收手了');
EXPLAIN(KKM>EMA(KKM,4) AND KKM>REF(KKM,1),'快速介入');
EXPLAIN(KKM>EMA(KKM,4) AND KKM<REF(KKM,1),'休息观望~');
EXPLAIN(KKM<EMA(KKM,4) AND KKM>REF(KKM,1),'有防御能力');
EXPLAIN(KKM<EMA(KKM,4) AND KKM<REF(KKM,1),'风险较大');

飞狐魔鬼线主图指标公式

 

相关文章