在线检测未来函数

大智慧腾天通道主图指标公式

来源:Internet,编辑:股旁网,2015-04-08

N:=13;
ZC:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v)/100);
『重心』:IF(VOL>0,zc,C),LINETHICK0,colorred;
{大通道}
KB713:=MA(HHV(MA(CLOSE,3),77),3);
KB75:=MA(LLV(MA(CLOSE,3),77),7);
『目标』:MA(HHV(MA(CLOSE,3),77),7),COLORffaacc,DOTLINE;
中线』:EMA(((KB713 + KB75) / 2),5),COLORffaacc,DOTLINE;
『防线』:MA(LLV(MA(CLOSE,3),77),3),COLORffaacc,DOTLINE;
{boll部分}
『M20』:MA(C,20),color00FF00;
『上轨』: 『M20』+ 2*STD(CLOSE,20),color00cccc,linethick2;
『下轨』: 『M20』- 2*STD(CLOSE,20),color00cccc,linethick2;
{黄金分割线}
lhnh:=BARSLAST(DISPSTATUS=1)+1;
hh:=HHV(h ,lhnh);
ll:=llV(l ,lhnh);
『金38』:(ll+(hh-ll)*0.618),coloryellow,linethick0;
『金50』:(ll+(hh-ll)*0.5),coloryellow,linethick0;
『金62』:(ll+(hh-ll)*0.382),coloryellow,linethick0;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.618,' 38%'),coloryellow;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.5,' 50%'),coloryellow;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.382,' 62%'),coloryellow;
FILLRGN(ll+(hh-ll)*0.60182,ll+(hh-ll)*0.63418,c>0,995599),layer7;
FILLRGN(ll+(hh-ll)*0.48382,ll+(hh-ll)*0.51618,c>0,995599),layer7;
FILLRGN(ll+(hh-ll)*0.39818,ll+(hh-ll)*0.36582,c>0,995599),layer7;
hh,colorff00ff,pointdot,layer7;
ll,colorff00ff,pointdot,layer7;
X:=『重心』>=MA(『重心』,n);
{k线部分}
{1、多头市场}
stickline(x,h,l,0,1),COLOR0000FF;
stickline(x and c>=o,O,C,5,0),COLOR0000FF;
stickline(x and c<o,O,C,5,1),COLOR0000FF;
{2、空头市场}
stickline(not(x),H,L,1,0),COLORFFBB00;
stickline(not(x) and c<o,O,C,5,0),COLORFFBB00;
stickline(not(x) and c>=o,O,C,5,1),COLORFFBB00;

大智慧腾天通道主图指标公式

 

相关文章