在线检测未来函数

通达信趋势量能王指标公式

来源:Internet,编辑:股旁网,2015-04-08

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR4:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,10))/(0.015*AVEDEV(VAR5,10));
VAR7:=(VAR5-MA(VAR5,30))/(0.015*AVEDEV(VAR5,30));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
趋势: VAR3;
顶线: IF(VARB<90,VARB,100);
多方: IF(VAR1>0,VAR1,0), LINESTICK;
空方: 0-IF(VAR1<0,VAR2,0), LINESTICK;
抄底: VAR20 AND PWINNER(5,CLOSE)<1.1, COLORRED;
预警系统: IF(VAR7>=200 AND VAR6>=150 OR CROSS(65,多方),15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+65,COLORCYAN;
STICKLINE(VAR3<=REF(VAR4,1),VAR3,VAR4,8,0), COLORWHITE;
STICKLINE(VAR3>REF(VAR4,1),VAR3,VAR4,8,0), COLORRED;
VAR21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
VAR23:=多方>60 AND 预警系统>65 AND 顶线=100;
VAR24:=多方>48 AND 预警系统>65 AND 顶线<100;
VAR25:=空方<-38 AND 预警系统<65;
VAR26:=抄底>50 AND 顶线<90;
VAR27:=VAR3>REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR28:=VAR3<=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=65 AND 抄底=0 AND 空方>=REF(空方,1) AND VARC<REF(VARD,1);
DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,10,'上升通道!'), COLORYELLOW;
VAR29:=DRAWTEXT(VAR22 AND COUNT(VAR22,30)=1,55,'下降通道!');
VAR2A:=DRAWTEXT(VAR23 AND COUNT(VAR23,30)=1,55,'上涨过急!');
VAR2B:=DRAWTEXT(VAR24 AND COUNT(VAR24,30)=1,75,'庄家出货!');
VAR2C:=DRAWTEXT(VAR25 AND COUNT(VAR25,30)=1,50,'有小反弹!');
VAR2D:=DRAWTEXT(VAR26 AND COUNT(VAR26,30)=1,30,'抢反弹!');
VAR2E:=DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,-10,'资金进场!');
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,90,'见顶回落!'),COLORYELLOW;

通达信趋势量能王指标公式

 

相关文章