在线检测未来函数

飞狐看跌30主图指标公式

来源:Internet,编辑:股旁网,2015-04-10

现高点:PEAK(h,10,1),LINETHICK3;
加码价:=(c-REF(c,18))/18+(MA(c,18)*1.004);
年波动:=VOLO(C,90,250),LINETHICK0;
百分百换手:=SUMBARS(VOL,CAPITAL),PRECISION0,LINETHICK0;
跌3:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*1.382,PRECISION2;
跌10:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*1.3,PRECISION2,LINETHICK3;
跌15:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*1.191,PRECISION2;
跌23:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*1.1,PRECISION2;
跌30:现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0),PRECISION2,LINETHICK3;
跌35:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*0.9,PRECISION2,LINETHICK0;
跌40:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*0.809,PRECISION2,LINETHICK0;
跌50:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*0.7,PRECISION2,LINETHICK0;
跌60:(现高点-OPTION(1,百分百换手,现高点,现高点*1.3,0.06,年波动,0))*0.618,PRECISION2,LINETHICK0;
BWMFI:=(HIGH-LOW)*10000/VOL;//市场促进指数
STICKLINE((VOL>REF(VOL,1) AND BWMFI>REF(BWMFI,1)),o,c,6,0),colorred;
STICKLINE((VOL>REF(VOL,1) AND BWMFI>REF(BWMFI,1)),l,h,0,0),colorred;
STICKLINE(( VOL<REF(VOL,1) AND BWMFI<REF(BWMFI,1)),o,c,6,0),COLORGREEN;
STICKLINE(( VOL<REF(VOL,1) AND BWMFI<REF(BWMFI,1)),l,h,0,0),COLORGREEN;
STICKLINE(( VOL<REF(VOL,1) AND BWMFI>REF(BWMFI,1)),o,c,6,0),colorblue;
STICKLINE(( VOL<REF(VOL,1) AND BWMFI>REF(BWMFI,1)),l,h,0,0),colorblue;
STICKLINE(( VOL>REF(VOL,1) AND BWMFI<REF(BWMFI,1)),o,c,6,0),COLORYELLOW;
STICKLINE(( VOL>REF(VOL,1) AND BWMFI<REF(BWMFI,1)),l,h,0,0),COLORYELLOW;
【绿灯】:( VOL>REF(VOL,1) AND BWMFI>REF(BWMFI,1)),COLORRED,LINETHICK0;
【衰退】:( VOL<REF(VOL,1) AND BWMFI<REF(BWMFI,1)),COLORGREEN,LINETHICK0;
【伪装】:( VOL<REF(VOL,1) AND BWMFI>REF(BWMFI,1)),colorblue,LINETHICK0;
【蛰伏】:( VOL>REF(VOL,1) AND BWMFI<REF(BWMFI,1)),COLORYELLOW,LINETHICK0;
DRAWTEXTEX(CLOSE,1,1,50,'现高点:'+NUMTOSTR(现高点,2)),COLORWHITE;
DRAWTEXTEX(CLOSE,1,150,50,'支撑 1:'+NUMTOSTR(跌10,2)),COLORGREEN;
DRAWTEXTEX(CLOSE,1,300,50,'支撑 2:'+NUMTOSTR(跌15,2)),COLORWHITE;
DRAWTEXTEX(CLOSE,1,450,50,'支撑 3:'+NUMTOSTR(跌23,2)),COLORBLUE;
DRAWTEXTEX(CLOSE,1,600,50,'支撑 4:'+NUMTOSTR(跌30,2)),COLORMAGENTA;
前高点:REF(现高点,1);
c;

飞狐看跌30主图指标公式

 

相关文章