在线检测未来函数

大智慧决胜王生命线主图指标公式

来源:Internet,编辑:股旁网,2015-04-14

生命线:ema(c,24),colorwhite,linethick2;
A:=ref(生命线,24);
mtm:=close-ref(close,1);
dx:=100*ema(ema(mtm,6),6)/ema(ema(abs(mtm),6),6);
dy:=hhv(dx,2)=hhv(dx,7) and count(dx>50,2) and cross(ma(dx,2),dx);
lc:=ref(close,1);
rsi:=sma(max(close-lc,0),6,1)/sma(abs(close-lc),6,1)*100;
多头线:EMA(C,1),COLORYELLOW;
空头线:EMA(C,5),COLOR00FF00;
均衡线:EMA(空头线,5),COLORWHITE;
varF1:=COUNT(CROSS(多头线,均衡线),2)=1;
varF2:=COUNT(CROSS(空头线,均衡线),2)=1;
ZAI:=FILTER(varF1 AND varF2,2);
DRAWTEXT(ZAI,均衡线*0.98,' 主升行情'),color00ff00;
stickline(生命线>=A,high,low,0,0),colorff00ff;
stickline(生命线>=A,open,close,4,0),colorff00ff;
stickline(cross(生命线,A),high,low,0,0),colorred;
stickline(cross(生命线,A),open,close,4,0),colorred;
drawtext(cross(生命线,A),low*0.98,'▲'),colorred;
drawtext(cross(生命线,A),low*0.975,'∣'),colorred;
drawtext(cross(生命线,A),low*0.975,'‖'),colorred;
drawtext(cross(生命线,A),low*0.97,'∣'),colorred;
drawtext(cross(生命线,A),low*0.97,'‖'),colorred;
drawtext(cross(生命线,A),low*0.965,'∣'),colorred;
drawtext(cross(生命线,A),low*0.965,'‖'),colorred;
stickline(生命线<A,high,low,0,0),colorcccccc;
stickline(生命线<A,open,close,4,0),colorcccccc;
stickline(cross(A,生命线),high,low,0,0),color00ff00;
stickline(cross(A,生命线),open,close,4,0),color00ff00;
drawtext(cross(A,生命线),high*1.02,'▼'),color00ff00;
drawtext(cross(A,生命线),high*1.025,'∣'),color00ff00;
drawtext(cross(A,生命线),high*1.025,'‖'),color00ff00;
drawtext(cross(A,生命线),high*1.03,'∣'),color00ff00;
drawtext(cross(A,生命线),high*1.03,'‖'),color00ff00;
drawtext(cross(A,生命线),high*1.035,'∣'),color00ff00;
drawtext(cross(A,生命线),high*1.035,'‖'),color00ff00;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),8);
DRAWTEXTREL(2,5,'【决胜王生命线】'),linethick3,colorwhite;
{DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'S '),colorFFFF34;}
dp:=if(c=INDEXC,0,1);gj:=AMOUNT/v/100;
上线:=sma(c,6.5,1);
下线:=sma(c,13.5,1);
上线1:=sma(c,3,1);
下线1:=sma(c,8,1);
STICKLINE(上线>下线,上线,下线,2.5,0),colorred,linethick2;
stickline(下线>上线,上线,下线,2.5,0),coloryellow,linethick2;
DRAWTEXT( cross(上线,下线),low*0.98,'▲全仓买' ),color00ff00;
drawtext(cross(下线1,上线1),h*1.02,'▼清仓'),coloryellow;
减仓:=filter(cross(80,rsi) or dy,5);
drawtext(减仓 and 生命线>A,high*1.03,'○'),colorblue;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(if(CLOSE<D and VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'▲抄底'),coloryellow;
VA1:=EMA(c,8);
VA2:=EMA(c,28);
DRAWTEXT(CROSS(VA2,VA1),VA1*1.10,'●全仓卖'),COLORYELLOW;
x1:=(3*C+H+L+O)/6;
x2:=EMA(x1,10);
x3:=REF(x2,1);
XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0) and x2>x3,l-0.1,'●反弹'),COLORGREEN;
DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/
4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0) and x2>x3,l-0.4,'●加仓'),ColorFF5ED8;
DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/
4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0) and x2>x3,l-0.4,'●加仓'),ColorFF5ED8;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,29)*1.01,10);
DRAWICON(CROSS(V1,V2),V2,1);
V3:=EMA(CLOSE,10);
V4:=EMA(EMA(CLOSE,60)*0.99,10);
DRAWICON(CROSS(V3,V4),V4,1);
Var34:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
Var35:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
Var36:=IF(Var34>0.010,0.900,1) AND IF(Var34>(-0.025),1,1.200);
Var37:=Var36*(Var35-Var34)*100;
Var38:=SUM(Var37,10);
Var310:=Var38>20;
Var326:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE,1)*1.0 AND CLOSE,88,0);
Var327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND Var326>0,91,0);
DRAWICON(Var310>0 AND Var327=0,HIGH*1.01,5);
STICKLINE(Var327>90,LOW*0.99,LOW*0.95,2,0),COLORYELLOW;
STICKLINE(C<=O,C,O,3,0),COLORFF2020;
DRAWTEXT(VAR327>90,LOW*0.95,'出击'),COLORYELLOW;

大智慧决胜王生命线主图指标公式

 

相关文章