在线检测未来函数

通达信波段启动主图及选股指标公式

来源:Internet,编辑:股旁网,2015-04-14

M5:MA(C,5);
M60:=MA(C,60);
M120:=MA(C,120);
M250:=MA(C,250);
TJ:=M60>=REF(M60,1) AND M120>=REF(M120,1) AND M250>=REF(M250,1);
T:=BARSLAST(CROSS(TJ,0.5));
TJA:=M5>MAX(MAX(M60,M120),M250) AND TJ;
TJB:=EVERY(TJA,T+1);
TJC:=V=HHV(V,T+1) AND C>REF(C,1)*1.03;
AA:=(ATAN((M5/REF(M5,5)-1)*100)*180/3.1415926);
LA:=REF(AA,LLVBARS(L,10));
ZF:=EVERY(RANGE((C-REF(C,1))/REF(C,1)*100,-5,5),4);
XG:=LA<-70 AND TJC AND TJB AND AA>80 AND REF(ZF,1);
STICKLINE(CROSS(XG,0.5),C,O,1.8,0),COLORLIRED;
STICKLINE(CROSS(XG,0.5),H,L,0,0),COLORLIRED;
DRAWTEXT(CROSS(XG,0.5),L*0.98,'启动点'),COLORYELLOW;

{
选股公式:

M5:=MA(C,5);
M60:=MA(C,60);
M120:=MA(C,120);
M250:=MA(C,250);
TJ:=M60>=REF(M60,1) AND M120>=REF(M120,1) AND M250>=REF(M250,1);
T:=BARSLAST(CROSS(TJ,0.5));
TJA:=M5>MAX(MAX(M60,M120),M250) AND TJ;
TJB:=EVERY(TJA,T+1);
TJC:=V=HHV(V,T+1) AND C>REF(C,1)*1.03;
AA:=(ATAN((M5/REF(M5,5)-1)*100)*180/3.1415926);
LA:=REF(AA,LLVBARS(L,10));
ZF:=EVERY(RANGE((C-REF(C,1))/REF(C,1)*100,-5,5),4);
XG:LA<-70 AND TJC AND TJB AND AA>80 AND REF(ZF,1);
}

通达信波段启动主图及选股指标公式

 

相关文章