在线检测未来函数

飞狐空间价位指标公式

来源:Internet,编辑:股旁网,2015-04-19

P00:=ROUND((((HIGH + LOW) + (CLOSE * 2)) / 4));
R100:=ROUND(((2 * P00) - LOW));
S100:=ROUND(((2 * P00) - HIGH));
R200:=ROUND((P00 + (R100 - S100)));
多空00:=ROUND((((HIGH + LOW) + (CLOSE * 2)) / 4));
S00:=ROUND(((2 * P00) - HIGH));
S200:=ROUND((P00 - (R100 - S100)));
P:=REF(P00,1);
R1:=REF(R100,1);
S1:=REF(S100,1);
第二压力:REF(R200,1),LINETHICK0,colorFF00;
第一压力:REF(R100,1),LINETHICK0,colorFF00;
多空位:(REF(多空00,1) + 1),LINETHICK0,colorFFFF;
第一支撑:REF(S00,1),LINETHICK0,colorFF00;
第二支撑:REF(S200,1),LINETHICK0,colorFF00;
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
多头成交:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,8,1),colorFF;
空头成交:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,8,1),colorFF00;
向上攻击量:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,8,0),colorFF;
向下攻击量:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,8,0),colorFF00;
上探量:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,8,0),colorCCCC66;
下探量:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,8,0),colorFF6633;
相对地量:STICKLINE(((VAR9 > 3) AND (VOL < (MA(VOL,3) / 2))),0,VOL,2.5,0),colorFFFF00;
地量:DRAWTEXT(((VAR9 > 2) AND (VOL < (MA(VOL,2) / 2))),VOL,'.'),colorFFFF00;
放量:STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2.5,0),colorFFFFFF;
逢高出货:DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR7 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'高出'),colorFF00;
逢低跟进:DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'低进'),colorFF00FF;
强势参与:DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'攻'),colorFFFF;
空头释放:DRAWTEXT(((((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)) AND ((VAR6 / VOL) > 0.7)) AND VARC) AND (VAR6 > MA(VOL,5))),(VAR6 * 2),'放'),colorFF00;
MA5:=MA(VOL,5);
MA10:=MA(VOL,10);
MA20:=MA(VOL,20);

飞狐空间价位指标公式

 

相关文章