在线检测未来函数

通达信OBV和MACD结合指标公式

来源:Internet,编辑:股旁网,2015-04-20

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0),COLORWHITE;
MAOBV:=MA(OBV,30);
零点:(CONST(LLV(OBV,90))+CONST(HHV(OBV,90)))/2,CIRCLEDOT,COLORWHITE;
DI:=EMA(CLOSE,12)-EMA(CLOSE,26);
F分:=CONST(LLV(DI,90));
F百:=CONST(HHV(DI,90))-F分;
点:=CONST(LLV(OBV,90));
基:=CONST(HHV(OBV,90))-点;
F比:=(DI-F分)/F百;
XFX:=F比*基+点;
DIF:=XFX,LINETHICK2;
DEA:=EMA(DIF,9),LINETHICK2;
MACD:(DIF-DEA)*2+零点;
STICKLINE(MACD>零点,零点,MACD,0,0),COLORRED;
STICKLINE(MACD<零点,零点,MACD,0,0),COLORCYAN;
MAV:=MA(VOL,30);
DRAWICON(VOL>MA(VOL,30)*3 AND CLOSE>REF(CLOSE,1),零点,1);
DRAWICON(VOL>MA(VOL,30)*3 AND CLOSE>REF(CLOSE,1) AND REF(VOL,1)>MA(VOL,30)*3,零点+10,11);

通达信OBV和MACD结合指标公式

 

相关文章