在线检测未来函数

通达信简单综合主图指标公式

来源:Internet,编辑:股旁网,2015-04-24

M1:=5;
M2:=10;
M3:=20;
M4:=60;
P1:=(CROSS(MA(CLOSE,3),MA(CLOSE,13))&&MA(CLOSE,13)>REF(MA(CLOSE,13),1));
启动成本:=REF(LOW,P1),COLORMAGENTA;
VAR1:=LLV(LOW,0);
VAR2:=HHV(HIGH,0);
VAR3:=VAR2-VAR1;
低:= VAR1;
H1:= VAR3*0.191+VAR1;
H2:= VAR3*0.382+VAR1;
H3:= VAR3*0.5+VAR1;
H4:= VAR3*0.618+VAR1;
H5:= VAR3*0.809+VAR1;
高:= VAR2;
顶点:REFDATE(高,DATE),COLORRED,POINTDOT;{顶点--红色虚线:表示股票当天冲到的最高点,不是黄金分割压力}
%19.8:REFDATE(H1,DATE),COLOR0050FF,POINTDOT;
%38.2:REFDATE(H2,DATE),COLOR0075FF,POINTDOT;
%50:REFDATE(H3,DATE),COLOR00A0FF,POINTDOT;
%61.8:REFDATE(H4,DATE),COLOR00C5FF,POINTDOT;
%80.9:REFDATE(H5,DATE),COLOR00E0FF,POINTDOT;
低点:REFDATE(低,DATE),COLORGREEN,POINTDOT;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;
DRAWTEXT(ISLASTBAR,%19.8,'%19.8'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=5,顶点,CON2STR(顶点,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=5,%19.8,CON2STR(%19.8,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=5,%38.2,CON2STR(%38.2,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=5,%50,CON2STR(%50,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=5,%61.8,CON2STR(%61.8,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=5,%80.9,CON2STR(%80.9,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=5,低点,CON2STR(低点,2)),COLORWHITE;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);

通达信简单综合主图指标公式

 

相关文章