在线检测未来函数

通达信奔走舒畅主图指标公式

来源:Internet,编辑:股旁网,2015-04-30

A:=(3*C+L+O+H)/6;
B:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
多:MA(B,2),COLORRED,LINETHICK2;
空:MA(B,3),COLORBLUE,LINETHICK2;
操作:MA(B,13),COLORYELLOW, LINETHICK2;
波段牛熊:MA(B,34),COLORGREEN;
长期牛熊:MA(B,233),COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(FILTER(c>操作 and BU,20),LOW*0.985,'奔');
DRAWTEXT(FILTER(c<操作 and SEL,20),HIGH*1.015,'走');
STICKLINE( CLOSE>OPEN AND 买线>=卖线,HIGH,CLOSE,0,0),COLOR0000AA;
STICKLINE( CLOSE>OPEN AND 买线>=卖线,LOW,OPEN,0,0),COLOR0000AA;
STICKLINE( CLOSE>OPEN AND 买线>=卖线,CLOSE,OPEN,8,1),COLOR0000AA;
STICKLINE( CLOSE<OPEN AND 买线>=卖线,HIGH,LOW,0,0),COLOR0000AA;
STICKLINE( CLOSE<OPEN AND 买线>=卖线,CLOSE,OPEN,8,0),COLOR0000AA;
STICKLINE( CLOSE>OPEN AND 买线<卖线,HIGH,CLOSE,0,0),COLORAAAA00;
STICKLINE( CLOSE>OPEN AND 买线<卖线,LOW,OPEN,0,0),COLORAAAA00;
STICKLINE( CLOSE>OPEN AND 买线<卖线,CLOSE,OPEN,8,1),COLORAAAA00;
STICKLINE( CLOSE<OPEN AND 买线<卖线,HIGH,LOW,0,0),COLORAAAA00;
STICKLINE( CLOSE<OPEN AND 买线<卖线,CLOSE,OPEN,8,0),COLORAAAA00;

通达信奔走舒畅主图指标公式

 

相关文章