在线检测未来函数

通达信大雁南飞主图指标公式

来源:Internet,编辑:股旁网,2015-04-30

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,1),COLORRED;
STICKLINE(CLOSE>OPEN,HIGH,CLOSE,0,0),COLORRED;
STICKLINE(CLOSE>OPEN,LOW,OPEN,0,0),COLORRED;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,8,0),COLOR009933;
STICKLINE(CLOSE<OPEN,HIGH,LOW,0,0),COLOR009933;
STICKLINE(CLOSE==OPEN,CLOSE,OPEN,8,0),COLORWHITE;
STICKLINE(CLOSE==OPEN,HIGH,LOW,0,0),COLORWHITE;
MID:=(3*C+L+H)/5;
纯粹趋势:=WMA(MID,20);
中位价:=((MAX(CLOSE,OPEN)-MIN(CLOSE,OPEN))/2)+MIN(CLOSE,OPEN);
回升:=中位价>REF(中位价,1) AND REF(中位价,1)<REF(中位价,2) AND REF(中位价,2)<REF(中位价,3) AND REF(C,1)<=REF(C,2),nodraw;
T1:=纯粹趋势>REF(纯粹趋势,1);
启动点:=T1==1 AND REF(T1,1)==0,nodraw;
启动时长:=BARSLAST(启动点)+1,NODRAW;
顶部过滤:=NOT(EXIST(纯粹趋势<=REF(纯粹趋势,1),5));
大雁南飞1:=回升 AND T1==1 AND CLOSE>OPEN AND 顶部过滤 AND 启动时长>5 AND CLOSE>纯粹趋势,nodraw;
大雁南飞:=COUNT(大雁南飞1,启动时长)<=2 AND 大雁南飞1,NODRAW;
大雁南飞第一式:大雁南飞,nodraw,coloRYELLOW;
drawicon(大雁南飞,low,1);
STICKLINE(大雁南飞,CLOSE,OPEN,8,1),COLORYELLOW;
STICKLINE(大雁南飞,HIGH,CLOSE,0,0),COLORYELLOW;
STICKLINE(大雁南飞,LOW,OPEN,0,0),COLORYELLOW;
绘图:=BACKSET(大雁南飞,4) AND 大雁南飞==0,nodraw;
STICKLINE(绘图,CLOSE,OPEN,8,0),COLORYELLOW;
STICKLINE(绘图,HIGH,LOW,0,0),COLORYELLOW;

通达信大雁南飞主图指标公式

 

相关文章