在线检测未来函数

通达信优化DMI指标公式

来源:Internet,编辑:股旁网,2015-04-30

DRAWBAND(20,RGB(0,80,120),0,RGB(0,200,0));
DRAWBAND(95,RGB(0,200,0),100,RGB(0,200,0));
DRAWTEXT_FIX(1,0.8,0.1,0,'绿头底部,翻红转势'),COLORWHITE;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:=EXPMEMA(ADX,6);
DRAWBAND(ADX,RGB(250,0,00),ADXR,RGB(100,80,200));
MDI1:DMM*100/MTR,COLORGREEN;
98;
黑:IF(ADX<20,19,0);
40;
60;
DRAWBAND(19,RGB(0,200,00),MDI1,RGB(0,200,0));
DRAWBAND(19,RGB(0,0,00),黑,RGB(0,0,0));
PDI1:DMP*100/MTR,LINETHICK2,COLORYELLOW;
高危区:95;

通达信优化DMI指标公式

 

相关文章