在线检测未来函数

通达信楼梯主图指标公式

来源:Internet,编辑:股旁网,2015-05-05

绘图范围:=IFF(BARSCOUNT(CLOSE)>120,1,0);
突破:=REF(EMA(CLOSE,14),1);
A1X:=(EMA(CLOSE,10)-突破)/突破*100;
多方:=IFF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IFF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*1.00,4,0),COLOR000098;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.95,4,0),COLOR000090;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.90,4,0),COLOR000088;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.85,4,0),COLOR000080;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.80,4,0),COLOR000078;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.75,4,0),COLOR000070;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.70,4,0),COLOR000068;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.65,4,0),COLOR000060;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.60,4,0),COLOR000058;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.55,4,0),COLOR000050;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.50,4,0),COLOR000048;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.45,4,0),COLOR000040;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.40,4,0),COLOR000038;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.35,4,0),COLOR000030;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.30,4,0),COLOR000028;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.25,4,0),COLOR000020;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.20,4,0),COLOR000018;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.15,4,0),COLOR000010;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.10,4,0),COLOR000008;
STICKLINE(绘图范围 AND A1X>=0,多方,多方+(突破-多方)*0.05,4,0),COLOR000000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.05,4,0),COLOR989800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.10,4,0),COLOR909000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.15,4,0),COLOR888800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.20,4,0),COLOR808000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.25,4,0),COLOR787800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.30,4,0),COLOR707000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.35,4,0),COLOR686800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.40,4,0),COLOR606000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.45,4,0),COLOR585800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.50,4,0),COLOR505000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.55,4,0),COLOR484800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.60,4,0),COLOR404000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.65,4,0),COLOR383800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.70,4,0),COLOR303000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.75,4,0),COLOR282800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.80,4,0),COLOR202000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.85,4,0),COLOR181800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.90,4,0),COLOR101000;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*0.95,4,0),COLOR080800;
STICKLINE(绘图范围 AND A1X<0,空方,突破-(突破-空方)*1.00,4,0),COLOR000000;
STICKLINE(绘图范围 AND CLOSE>OPEN,HIGH,LOW,0,0),COLORFF88FF;
STICKLINE(绘图范围 AND CLOSE>OPEN,CLOSE,OPEN,3,1),COLORFF88FF;
STICKLINE(绘图范围 AND CLOSE=OPEN,HIGH,LOW,0,0),COLORWHITE;
STICKLINE(绘图范围 AND CLOSE=OPEN,CLOSE,OPEN,3,0),COLORWHITE;
STICKLINE(绘图范围 AND CLOSE<OPEN,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(绘图范围 AND CLOSE<OPEN,CLOSE,OPEN,3,0),COLORGREEN;
多头:=A1X>=0 AND REF(A1X,1)<0;
转多头距离:=BARSLAST(转多头)+1;
多头中继:=LOW<突破 AND OPEN<突破 AND BETWEEN(转多头距离,10,30);
转空头:=A1X<0 AND REF(A1X,1)>=0;
转空头距离:=BARSLAST(转空头)+1;
空头中继:=HIGH>突破 AND OPEN>突破 AND BETWEEN(转空头距离,10,30);
买方空中加油:IFF(绘图范围 AND COUNT(多头中继,转多头距离)<=2 AND 多头中继 AND A1X>=0,突破,DRAWNULL),NODRAW,COLORYELLOW;
卖方空中加油:IFF(绘图范围 AND COUNT(空头中继,转空头距离)<=2 AND 空头中继 AND A1X<0,突破,DRAWNULL),NODRAW,COLORCYAN;
黄色点:=IFF(绘图范围 AND COUNT(多头中继,转多头距离)<=2 AND 多头中继 AND A1X>=0,1,0);
蓝色点:=IFF(绘图范围 AND COUNT(空头中继,转空头距离)<=2 AND 空头中继 AND A1X<0,1,0);
DRAWICON(黄色点,LOW*0.997,92);
DRAWICON(蓝色点,HIGH*1.007,93);
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
参考线试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,参考线试买,'----参考线试买------'),COLORYELLOW,LINETHICK4;
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
(VAR327>90,L*0.99,L*0.95,4,0), ;
DRAWTEXT(VAR327>90,LOW*0.95,'起爆'), ;

通达信楼梯主图指标公式

 

相关文章