在线检测未来函数

飞狐水都观音指标公式

来源:Internet,编辑:股旁网,2015-05-06

DRAWGBK(C, COLORRGB(000,888,999), COLORRGB(000,000,999),1);
昨收:=REF(C,1);
最高价偏离:=ABS(H-昨收);
最低价偏离:=ABS(L-昨收);
高低偏离:=ABS(H-REF(L,1));
昨K线长:=ABS(昨收-REF(O,1));
稳定性测度:=IF(最低价偏离>高低偏离 AND 最低价偏离>最高价偏离,最低价偏离+最高价偏离/2+昨K线长/4,高低偏离+昨K线长/4);
强弱测度:=C+(C-O)/2-REF(c,1);
振动系数:=强弱测度/稳定性测度;
振动量:=振动系数*MAX(最高价偏离,最低价偏离);
振动线:=SUM(振动量,0);
均125:=EMA(振动线,125);
PARTLINE(c,均125),Color004F00,linethick2;
均150:=EMA(振动线,150);
PARTLINE(c,均150),ColorFFAD00;
均175:=EMA(振动线,175);
PARTLINE(c,均175),ColorFF9100;
均200:=EMA(振动线,200);
PARTLINE(c,均200),ColorFF6000;
均225:=EMA(振动线,225);
PARTLINE(c,均225),ColorFF3F00;
均240:=EMA(振动线,240);
PARTLINE(c,均240),ColorFF3F00;
观音显圣:振动线>均125,ColorFA00FF,linethick0;
FILLRGN(NOT(观音显圣),均125,振动线+(均125-振动线)*0.75),Color004F00;
FILLRGN(NOT(观音显圣),振动线+(均125-振动线)*0.75,振动线+(均125-振动线)*0.5),Color007600;
FILLRGN(NOT(观音显圣),振动线+(均125-振动线)*0.5,振动线+(均125-振动线)*0.25),Color00AD00;
FILLRGN(NOT(观音显圣),振动线,振动线+(均125-振动线)*0.25),Color00DE00;
FILLRGN(观音显圣,均125,均125+(振动线-均125)*0.25),ColorFA00FF;
FILLRGN(观音显圣,均125+(振动线-均125)*0.25,均125+(振动线-均125)*0.5),ColorFA50FF;
FILLRGN(观音显圣,均125+(振动线-均125)*0.5,均125+(振动线-均125)*0.75),ColorFA93FF;
FILLRGN(观音显圣,振动线,均125+(振动线-均125)*0.75),ColorFFCCFF;
朝拜观音:FILTER(CROSS(振动线,均240),24),linethick0,Coloryellow;
DRAWICON(朝拜观音,均125,12);
慈航普渡:均125>=REF(均125,1),Colorred,linethick0;
PARTLINE(慈航普渡,均125),Colorred,linethick2;

飞狐水都观音指标公式

 

相关文章