在线检测未来函数

通达信KDJ调整主图指标公式

来源:Internet,编辑:股旁网,2015-05-06

{KDJ成分论}
上轨:SMA(HHV(HIGH,54),3,1),LINETHICK2,COLORBLUE;
下轨:SMA(LLV(LOW,54),3,1),LINETHICK2,COLORBLUE;
中:上轨/2+下轨/2,COLORBLUE;
{KDJ灵敏改造}
N:=54;
M:=54;
X:= REF(C,1);
R:=SMA(MAX(C-X,0),N,1)/SMA(ABS(C-X),N,1) *100;
RR:=SMA(MAX(C-X,0),N*2,1)/SMA(ABS(C-X),N*2,1) *100;
F1:=(R-LLV(R,M))/(HHV(R,M)-LLV(R,M));
F2:=(R-LLV(R,M*2))/(HHV(R,M*2)-LLV(R,M*2));
{KDJ线定位}
现状:F1*(上轨-下轨)+下轨,COLORFF00FF;
形势:MA(现状,5),COLORYELLOW;
趋势:SMA(F2*(上轨-下轨)+下轨,8,1),COLOR66FFFF,LINETHICK2;

通达信KDJ调整主图指标公式

 

相关文章