在线检测未来函数

通达信擒大牛及选股指标公式

来源:Internet,编辑:股旁网,2015-05-11

TJ1:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4:=TJ1 OR TJ2 OR TJ3;
TJ5:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9.00;
KCCC3:=中线/长线1<1+0.01*20.00;
擒大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5;
IF(擒大牛>0,70,0),COLOREA91B5,LINETHICK2;
DRAWTEXT(擒大牛>0,55,'擒大牛'),COLORRED,LINETHICK1;

{
选股公式:

TJ1:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4:=TJ1 OR TJ2 OR TJ3;
TJ5:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9.00;
KCCC3:=中线/长线1<1+0.01*20.00;
擒大牛选股:KAAA3 AND KBBB3 AND KCCC3 AND TJ5;
}

通达信擒大牛及选股指标公式

 

相关文章