在线检测未来函数

飞狐锦绣前程指标公式

来源:Internet,编辑:股旁网,2015-05-14

V2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
V3:=(MA(VOL,2) / MA(VOL,10));
VAR1:=SUM(IF((CLOSE > REF(CLOSE,1)),VOL,IF((CLOSE < REF(CLOSE,1)),(0 - VOL),0)),0);
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=(IF((CLOSE > LLV(CLOSE,VAR2)),1,(0 - 1)) * IF((VAR1 > LLV(VAR1,VAR2)),1,(0 - 1)));
VAR4:=IF((VAR3 = (0 - 1)),1,0);
VAR5:=(COUNT((VAR4 = 1),8) > 3);
VAR6:=((SUM(AMOUNT,13) / ((AMOUNT / VOL) / 100)) / 100);
VAR7:=DMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),(VOL / VAR6));
VAR8:=((((CLOSE - VAR7) / VAR7) * 100) < (0 - 17));
VAR9:=(((CLOSE - MIN((REF(CLOSE,5) * 0.83),(REF(CLOSE,21) * 0.72))) / CLOSE) < 0.05);
VAR31:=MA(HHV(HIGH,488),18);
VAR32:=MA(HHV(HIGH,220),18);
VAR33:=MA(HHV(HIGH,98),18);
VAR34:=MA(LLV(LOW,488),18);
VAR35:=MA(LLV(LOW,220),18);
VAR36:=MA(LLV(LOW,98),18);
VAR37:=MA((((((((VAR34 * 0.96) + (VAR35 * 0.96)) + (VAR36 * 0.96)) + (VAR31 * 0.558)) + (VAR32 * 0.558)) + (VAR33 * 0.558)) / 6),18);
VAR38:=MA((((((((VAR34 * 1.25) + (VAR35 * 1.23)) + (VAR36 * 1.2)) + (VAR31 * 0.55)) + (VAR32 * 0.55)) + (VAR33 * 0.65)) / 6),18);
VAR39:=MA((((((((VAR34 * 1.3) + (VAR35 * 1.3)) + (VAR36 * 1.3)) + (VAR31 * 0.68)) + (VAR32 * 0.68)) + (VAR33 * 0.68)) / 6),18);
VAR40:=MA((((((VAR37 * 3) + (VAR38 * 2)) + VAR39) / 6) * 1.738),18);
VAR41:=VAR40;
VAR42:=LOW;
VAR43:=REF(LOW,1);
VAR44:=((SMA(ABS((VAR42 - VAR43)),3,1) / SMA(MAX((VAR42 - VAR43),0),3,1)) * 100);
VAR45:=MA(IF(((CLOSE * 1.35) <= VAR41),(VAR44 * 10),(VAR44 / 10)),3);
VAR46:=LLV(LOW,30);
VAR47:=HHV(VAR45,30);
VAR49:=IF((LOW <= VAR46),((VAR45 + (VAR47 * 2)) / 2),0);
RSW:=((VAR8 AND VAR9) AND VAR5);
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
A5:=((((OPEN < MA1) AND (OPEN < MA2)) OR ((OPEN < MA2) AND (OPEN < MA3))) OR ((OPEN < MA1) AND (OPEN < MA3)));
A4:=(((OPEN < MA1) OR (OPEN < MA2)) OR (OPEN < MA3));
AA:=(CLOSE > MAX(MA1,MAX(MA2,MA3)));
VAR12:=((VOL / MA(VOL,30)) > 1.2);
VAR13:=((CLOSE / REF(CLOSE,1)) > 1.049);
VAR14:=(((A5 AND AA) AND VAR12) AND VAR13);
黄金:((RSW > 0) AND (REF(RSW,1) = 0)),colorFF55ff;
DRAWTEXT(((RSW > 0) AND (REF(RSW,1) = 0)),0.5,'黄金信号'),colorFFFFee;
白银:IF((((((((REF(CLOSE,13) - CLOSE) / REF(CLOSE,13)) * 100) > 15) AND ((SUM((VOL / CAPITAL),13) * 100) < 18)) AND (((VOL / CAPITAL) * 100) < 2.5)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 100) < 8)),1,0),colorFFFFFF;
DRAWTEXT(((黄金 AND 白银) = 1),1,'★'),colorFFFFee;
绿宝石:((((A5 AND AA) AND VAR12) AND VAR13) AND ((REF(BARSLAST(VAR14),1) > 60) OR (BARSSINCE(VAR14) = 0))),color00FF00;
准备出击:MA((VAR49 AND (CLOSE < COST(0.5))),9),colorFF9911;
VAR15:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR16:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR48:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR49:=(((VAR15 + (2 * VAR16)) + (3 * VAR48)) / 6);
VAR50:=MA(VAR49,3);
警示:IF((VAR50 > 9),1,0.85),LINETHICK1,colorFFFF00;
DRAWTEXT((VAR50 > 9),0.9,'顶'),colorFFFF00;

飞狐锦绣前程指标公式

 

相关文章