在线检测未来函数

通达信涨停战队主图指标公式

来源:Internet,编辑:股旁网,2015-05-15

X:=(MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,7)+MA(CLOSE,13)+MA(C,21))/5;
牛熊线:X,COLORWHITE,LINETHICK2;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.85,O,C,3.2,0),COLOR0000FF;
STICKLINE(ZDF<-9.85,O,C,3.2,0),COLORFF0000;
DRAWTEXT(ZDF>9.85,L*0.95,'涨停'),COLORRED;
DRAWTEXT(ZDF<-9.85,L*0.96,'跌停'),COLORBLUE;
A4:=MA(C,20);
A5:=(C>MA(C,5));
A6:=(MA(C,5)>MA(C,10));
A7:=(C>MA(C,10));A8:=(MA(C,5)>MA(C,20));
A9:=(C>MA(C,20));A10:=REF(A4,1);
A11:=(A4>A10);
AVX:=(((((IF(A5,10,(0-10))+IF(A6,10,(0-10)))+IF(A7,10,(0-10)))+
IF(A8,10,(0-10)))+IF(A9,10,(0-10)))+IF(A11,10,(0-10)));
SC:=REF(AVX,1)<=0 AND AVX>0;
A1:=AVX>10 AND AVX>=REF(AVX,1) AND AVX>=REF(AVX,2);
A2:=AVX=60;
A3:=SC OR A1 OR A2 ;
STICKLINE(A3,O,C,1.3,0),COLORMAGENTA;
STICKLINE(A2,O,C,1.3,0),COLORYELLOW;
CX:=BARSLAST(NOT(A3));
CX1:=BARSLAST(NOT(A2));
STICKLINE(A3>0,REF(L,CX)*0.96,REF(L,CX)*0.965,4,0)COLOR0000FF;
DRAWNUMBER(A2,REF(L,CX)*0.95,CX1)COLORYELLOW;
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
DK:=(MA((C-HY1)*28,2))*0.1;
HS:=V*100/CAPITAL;
ZL:=MA(HS,4);
DH:=MA(HS,9);
ZH:=MA(HS,17);
SH:=MA(HS,34);
JL:=(ZL+DH+ZH+SH)/4;
ZLNL:=(ZL-JL);
AA1:=DK>=0 AND DK>=REF(DK,1) AND C>=X;AA2:=ZLNL>=0 AND ZLNL>=REF(ZLNL,1) AND C>=X;
DRAWICON(AA2,L*0.97,27);

通达信涨停战队主图指标公式

 

相关文章