在线检测未来函数

通达信量价MACD分时主图指标公式

来源:Internet,编辑:股旁网,2015-05-18

{放量}
放量:=SUM(V,3)>REF(SUM(V,7),3)*2;
DRAWICON(放量=1 AND FILTER(放量=1,6),C,11);
DRAWTEXT(放量=1 AND FILTER(放量=1,6),C-C*0.015,'量'),COLORYELLOW;
{价}
现价:C,COLORMAGENTA,LINETHICK3;
均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK3;
绿跌:IF(均价<=REF(均价,1),均价,DRAWNULL),COLORGREEN,LINETHICK5;
蓝涨:IF(均价>=REF(均价,1),均价,DRAWNULL),COLORBLUE,LINETHICK5;
{分时MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
X:=CONST(HHV(ABS(C-DYNAINFO(3)),FROMOPEN))/CONST(HHV(ABS(DIF),FROMOPEN))*0.6;
DI:DIF*X+DYNAINFO(3),COLORGRAY;
DE:DEA*X+DYNAINFO(3),COLOR7700AA;
MAC:=MACD*X;
STICKLINE(MAC>0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORRED;
STICKLINE(MAC<0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORCYAN;
DRAWTEXT((CROSS(DIF,DEA) AND 蓝涨),C,'买'),COLORYELLOW;

通达信量价MACD分时主图指标公式

 

相关文章