在线检测未来函数

大智慧BOLL超跌主图指标公式

来源:Internet,编辑:股旁网,2015-05-20

P:=2;
N:=26;
涨幅:=(c-ref(c,1))/ref(c,1);
st判断:=STRCMP('st',STKNAME);
涨停:=if(st判断<1,涨幅>0.099,if(st判断=1, 涨幅>0.049,0));
MID : MA(CLOSE,N);
UPPER: MID + P*STD(CLOSE,N),COLOR006600;
LOWER: MID - P*STD(CLOSE,N),COLOR660066;
DRAWLINE(1,C,1,O,00),COLOR00FFFF ;
STICKLINE(1,L,H,1.8,0),COLOR333333;
STICKLINE(C>REF(C,1),O,C,1.5,0),COLORRED;
STICKLINE(C>REF(C,1)*1.095,O,C,5,0),COLOR0066FF;
STICKLINE(C>REF(C,1) AND O>C,O,C,1.5,0),COLOR990099;
STICKLINE(C<REF(C,1),O,C,1.5,0),COLORBLUE;
STICKLINE(C<REF(C,1)*0.9,O,C,5,0),COLORFFFF33;
STICKLINE(C<REF(C,1) AND O<C,O,C,1.5,0),COLOR00FF00;
A0:=C>REF(C,1) OR C=REF(C,1);
AA0:=L<LOWER;
AA1:=REF(AA0,1) AND C>LOWER AND A0 ;
AA2:=REF(AA0,1) AND L>LOWER ;
AA3:=REF(O,1)<LOWER AND C>LOWER;
AA4:=REF(O,1)<LOWER AND L>LOWER;
DRAWICON(AA1 AND NOT(REF(AA1,1)),L*0.98,7) ,ALIGN1;
AA5:=AA1 AND NOT(REF(AA1,1)) AND MID>REF(MID,1);

大智慧BOLL超跌主图指标公式

 

相关文章