在线检测未来函数

通达信量坑成交量及选股指标公式

来源:Internet,编辑:股旁网,2015-05-27

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5);
MAVOL2:MA(VOLUME,10);
N:=10;
V5:=MA(VOL,5);
HT:=HHVBARS(V5,60);
T:=BARSLAST(V5=REF(V5,HT));
LT:=LLVBARS(V5,30);
T1:=BARSLAST(V5=REF(V5,LT));
FD:=REF(V5,T)/REF(V5,T1);
TJ:=T>T1 AND CROSS(C,REF(H,T)) AND FD>N;
XG:=COUNT(TJ,T+1)=1 AND TJ;
XGT:=BARSLAST(XG);
QF:=BACKSET(XG,T1+1);
QFT:=BARSLAST(CROSS(QF=1,0.5));
QF1:=BACKSET(XG,T+1);
QFT1:=BARSLAST(CROSS(QF1=1,0.5));
A:=REFX(FD,BARSNEXT(QFT=0));
STICKLINE(QFT=0,VOL,0,1.5,0),COLORYELLOW;
STICKLINE(QFT1=0,VOL,0,1.5,0),COLORYELLOW;
NOTEXT1:DRAWLINE(QFT1=0,REF(V5,QFT1),QFT=0,REF(V5,QFT),0),COLORGREEN,LINETHICK2;
NOTEXT2:DRAWLINE(QFT=0,REF(V5,QFT),XGT=0,REF(V5,XGT),0),COLORGREEN,LINETHICK2;
NOTEXT:DRAWLINE(QFT1=0,REF(V5,QFT1),QFT1=28,REF(V5,QFT1),0),COLORWHITE,LINETHICK4;
DRAWTEXT(QFT1=0,NOTEXT*1.04,VARCAT(VARCAT('下一个量坑深:',VAR2STR(A,2)),'米'))COLORYELLOW;
DRAWICON(XG,V+1000,25);

{
选股公式:

N:=10;
V5:=MA(VOL,5);
HT:=HHVBARS(V5,60);
T:=BARSLAST(V5=REF(V5,HT));
LT:=LLVBARS(V5,30);
T1:=BARSLAST(V5=REF(V5,LT));
FD:=REF(V5,T)/REF(V5,T1);
TJ:=T>T1 AND CROSS(C,REF(H,T)) AND FD>N;
XG:COUNT(TJ,T+1)=1 AND TJ;
}

通达信量坑成交量及选股指标公式

 

相关文章