在线检测未来函数

大智慧火耗龟公主图指标公式

来源:Internet,编辑:股旁网,2015-05-28

M1: MA(CLOSE,5);
M2:= MA(CLOSE,10);
M3:= MA(CLOSE,30);
M4: MA(CLOSE,30);
Var1:=1;
Var2:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100;
Var3:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
Var4:=REF(Var2,1)<-20 AND Var3;
Var5:=REF(Var2,1)<-20 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
Var6:=FILTER(Var4 OR Var5,3);
Var7:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
Var8:=REF(Var2,1)>ABS(-20) AND Var7;
Var9:=REF(Var2,1)>ABS(-20) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
VarA:=FILTER(Var8 OR Var9,3);
VarB:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VarC:=REF(Var2,1)<-13 AND Var3;
VarD:=REF(Var2,1)<-13 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VarE:=FILTER(VarC OR VarD,3);
VarF:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
Var10:=REF(Var2,1)>ABS(-13) AND Var7;
Var11:=REF(Var2,1)>ABS(-13) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
Var12:=FILTER(Var10 OR Var11,3);
DRAWICON(Var6*Var1>0,LOW,1);
DRAWICON(VarA*Var1>0,HIGH,2);
DRAWTEXT(VarE*Var1>0,1.02*REF(CLOSE,1),'短线关注'),colorgreen;
DRAWTEXT(Var12*Var1>0,0.99*REF(CLOSE,1),'控制风险'),coloryellow;

大智慧火耗龟公主图指标公式

 

相关文章