在线检测未来函数

大智慧雷公柱指标公式

来源:Internet,编辑:股旁网,2015-06-01

ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=if(ff3<ff1,ff1,ff3);
ma13:=ma(c,13);
zdhm:=cross(c,dkkj) and cross(c,ma13) and cross(c,xkkj);
zhm:=cross(c,ma13) and cross(c,xkkj);
黑马:if(zdhm or zhm,20,0),coloryellow,pointdot;
stickline(大黑马>0,0,大黑马*1.1,1,0),colorwhite;
stickline(大黑马>0 and 大黑马<22,5,大黑马,1,0),colorred;
stickline(大黑马>0,0,大黑马*0.8,4,0),colorred;
stickline(大黑马>0,0,大黑马*0.4,8,0),colorred;
stickline(大黑马>0,0,大黑马*0.2,10,0),coloryellow;
stickline(大黑马>0,0,大黑马*0.1,10,0),colorffcc66;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
HSL:=((XVL / 20) / 1.15);
力度:(HSL / 1000),PRECIS0,LINETHICK0;QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
LLJX:=EMA(攻击流量,3);
周流量:=SUM(LLJX,5);
BB:=REF(周流量,1);
ZQZJJ:=(((周流量 - BB) / BB) * 100);
周增幅:IF(((周流量 > 0) AND (BB < 0)),ABS(ZQZJJ),IF((((周流量 < 0) AND (BB < 0)) AND (周流量 < BB)),(0 - ZQZJJ),ZQZJJ)),LINETHICK0;
J1:="macd.diff";
J2:="macd.dea";
J3:="kdj.k";
J4:="kdj.d";
VL:=REF(LOW,1); VH:=REF(H,1);
Var1:=SMA(ABS(H-Vh),13,1)/SMA(MAX(H-Vh,0),13,1)*100;
Var2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
Var3:=REF(CLOSE,1);
Var4:=MA(Var2,13);
Var5:=LLV(L,34);
Var6:=SMA(MAX(CLOSE-Var3,0),6,1)/SMA(ABS(CLOSE-Var3),6,1)*100;
var7:=CROSS(93,Var6);
Var8:=EMA(IF(L<=Var5,Var4,0),3);
var9:=H>LLV(l,0)*7;
var10:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
var11:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (var10 * 10.9);
T:=FILTER(IF(var11<=var10 AND Var8>REF(Var8,1),Var8*8,0),20);
T0:=FILTER(IF(CROSS(j4,j3) and SUM(j1>REF(j1,1),3)>3,CROSS(j4,j3) and CROSS(j2,j1),0),13);
T1:=FILTER(CROSS(j1,j2) and vol>REF(SUM(vol,5),1),3);
T2:=FILTER(var7 and C/(REF(C,1)-1)*100<>5 and var9 and vol>REF(SUM(vol,3),1),5);
DRAWTEXT(T0,T0,'注意洗盘'),color33FF00;
DRAWTEXT(T,T,'洗盘结束'),COLORRED;
DRAWTEXT(T1,T1,'主力加速'),color33FF00;
DRAWTEXT(T2,T2,'庄家逃跑'),color33FF00;;Ml5:=MA(CLOSE,5);
Ml10:=MA(CLOSE,10);
Ml20:=MA(CLOSE,20);
Ml30:=MA(CLOSE,30);
N1:=BARSLAST(CROSS(Ml5,Ml10));
N2:=BARSLAST(CROSS(Ml10,Ml5));
多:=IF(N1<N2,N1+1,0);
QSXS:=Ml5>Ml20 AND Ml10>Ml20 AND Ml20>REF(Ml20,1)
AND Ml30>REF(Ml30,1);
HKFJ:=HHV(多,5)>=2 AND QSXS AND Ml5>REF(Ml5,1) AND Ml5>Ml10;
航空飞机:HKFJ*多,colorwhite,LINETHICK2;LC := REF(c,1);
RSI1:=SMA(MAX(c-LC,0),5,1)/SMA(ABS(c-LC),5,1)*100;
RSI2:=SMA(MAX(c-LC,0),10,1)/SMA(ABS(c-LC),10,1)*100;
r1:=ema(rsi1,3);
r2:=ema(rsi2,3);
上升:(r1-r2),COLOR0000DD,LINETHICK2;
下降:-上升,colorblue,LINETHICK2;
;PARTLINE(上升>0,上升);
PARTLINE(上升>0,上升);短線:=(CLOSE-ma(CLOSE,13))/ma(CLOSE,13)*100;
極短 :=(CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*100;
雷公柱:=sma(短線,3,1);
反雷公柱:=sma(極短,3,1);
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱>0,0,雷公柱,2,0),color66ff00;STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,8,0),COLOR0000AA;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,7,0),COLOR0000BB;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,6,0),COLOR0000CC;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,5,0),COLOR0000DD;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,4,0),COLOR0000EE;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,3,0),COLOR0000FF;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱>0,0,雷公柱,2,0),COLORRED;STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,9,0),COLOR0000FF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,7,0),COLOR0033FF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,6,0),COLOR0055FF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,5,0),COLOR0077FF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,4,0),COLOR0099FF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,3,0),COLOR00BBFF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,2,0),COLOR00DDFF;
STICKLINE(反雷公柱<ref(反雷公柱,1) and 反雷公柱>0,0,反雷公柱,1,0),COLOR00FFFF;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,8,0),COLORFF0000;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,7,0),COLORFF3300;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,6,0),COLORFF5500;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,5,0),COLORFF7700;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,4,0),COLORFF9900;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,3,0),COLORFFBB00;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,2,0),COLORFFDD00;
STICKLINE(雷公柱>ref(雷公柱,1)and 雷公柱<0,0,雷公柱,1,0),COLORFFFF00;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,8,0),COLORFF0000;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,7,0),COLORFF3300;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,6,0),COLORFF5500;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,5,0),COLORFF7700;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,4,0),COLORFF9900;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,3,0),COLORFFBB00;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,2,0),COLORFFDD00;
STICKLINE(雷公柱<ref(雷公柱,1)and 雷公柱<0,0,雷公柱,1,0),COLORFFFF00;STICKLINE(反雷公柱>ref(反雷公柱,1)and 反雷公柱<0,0,反雷公柱,9,0),COLORYELLOW;

大智慧雷公柱指标公式

 

相关文章