在线检测未来函数

通达信一支三压主图指标公式

来源:Internet,编辑:股旁网,2015-06-01

M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
A:=M5>=M60 AND M10>=M60 AND M20>=M60;
T:=BARSLAST(CROSS(A,0.5));
HT:=HHVBARS(H,T+1);
NOTEXT1:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),ISLASTBAR,REF(H,T),0),COLORYELLOW,LINETHICK2;
NOTEXT2:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,REF(H,HT),1),COLORYELLOW,LINETHICK2;
NOTEXT3:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.382+REF(H,T),1),DOTLINE,COLORMAGENTA;
NOTEXT4:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.618+REF(H,T),1),DOTLINE,COLORGREEN;
STICKLINE(CURRBARSCOUNT=CONST(T)+1,C,O,1.8,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=CONST(T)+1,H,L,0,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=CONST(HT)+1,C,O,1.8,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=CONST(HT)+1,H,L,0,0),COLORYELLOW;
压力:NOTEXT2,NODRAW,COLORYELLOW;
支撑1:NOTEXT3,NODRAW,COLORMAGENTA;
支撑2:NOTEXT4,NODRAW,COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(T)+1,NOTEXT1*0.96,VARCAT(VARCAT('底部支撑价:',VAR2STR(NOTEXT1,2)),'元'))COLORYELLOW;

通达信一支三压主图指标公式

 

相关文章