在线检测未来函数

通达信最新优化组合黄金分割+单阳不破+趋势飘带+买卖点主图指标

来源:Internet,编辑:股旁网,2015-06-01

DRAWGBK(C>0,RGB(150,50,175),RGB(0,25,100),0,' ',0);
{DRAWGBK(O>C,RGB(360,0,10),RGB(10,0,1),0,'01',0);}
N8:=STRCAT(CON2STR(YEAR,0),'年');
Y8:=STRCAT(CON2STR(MONTH,0),'月');
R8:=STRCAT(CON2STR(DAY,0),'日');
N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL);
低:IF(CURRBARSCOUNT<=N/30,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/30,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/30,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
压力:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
低涨:IF(CURRBARSCOUNT<=N/30,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299,NODRAW;
顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;
低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;
STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;
DRAWBAND(高,RGB(200,200,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(0,190,0),警示,RGB(0,0,0));
DRAWBAND(警示,RGB(220,120,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(120,0,120),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(120, 0,0),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(80,80,80),低,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=N/30,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N/30,支撑,支撑,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,强势,强势,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,突破,突破,4,0),COLORABABAB;
STICKLINE(CURRBARSCOUNT<=N/30,警示,警示,4,0),COLOR00FFFF;
STICKLINE(CURRBARSCOUNT<=N/30,压力,压力,4,0),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,压力,'0.809'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,警示,'0.618'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,突破,'0.500'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,强势,'0.382'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'0.191'),COLOR00FFFF;
DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
DB:(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+
15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+
10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+
5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+
REF(DA,20))/210,COLORRED;
DC:MA(DB,5),COLORF0F000,LINETHICK1;
{DRAWBAND(DB,RGB(255,0,0),DC,RGB(0,255,0));}
DRAWBAND(DB,RGB(155,50,50),DC,RGB(83,123,68));
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
地量:=FILTER(LLV(AMOUNT,120)=AMOUNT,10);
STICKLINE(地量,CLOSE,OPEN,4,0),COLORGREEN;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(地量,LOW,' ↖地量'),COLORGREEN;
{价画直线指标 };
STICKLINE(ISLASTBAR,C,C,3333,-1),COLORWHITE;
{止盈止损}
买入价格:IF(CROSS((MACD.DIF),(MACD.DEA)),C,DRAWNULL),NODRAW;
AAA:=STICKLINE(买入价格,0,C,2,0),COLORRED;
AAC:=BARSLAST(AAA);
止盈价格:IF(C>=REF(C,AAC)*1.1,REF(C,AAC)*1.1,DRAWNULL),COLORMAGENTA,NODRAW;
止损价格:IF(C<=REF(C,AAC)*0.95,REF(C,AAC)*0.95,DRAWNULL),COLORGREEN,NODRAW;
{庄家成本}
A:=SUMBARS(V ,CAPITAL*1);{累计换手=100%的周期}
A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}
A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}
A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}
A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}
A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}
庄家成本:(5*A1+4*A2+3*A3+2*A4+A5)/15,DOTLINE,COLORWHITE;
IF(庄家成本>REF(庄家成本,1),庄家成本,DRAWNULL),COLORFF00FF,LINETHICK2;
{3D立体K线}
STICKLINE(C>O,C,O,3.2,0),COLOR000066;
STICKLINE(C>O,C,O,2.0,0),COLOR000077;
STICKLINE(C>O,C,O,1.5,0),COLOR000099;
STICKLINE(C>O,C,O,0.9,0),COLOR0000CC;
STICKLINE(C>O,C,O,0.5,0),COLOR0000FF;
STICKLINE(C>0,O,C,0,0),COLORFFFFFF;
STICKLINE(C<O,L,H,0,0),COLOR009900;
STICKLINE(C<O,C,O,3.2,0),COLOR009900;
STICKLINE(C<O,C,O,2.5,0),COLOR00BB00;
STICKLINE(C<O,C,O,1.5,0),COLOR00DD00;
STICKLINE(C<O,C,O,0.5,0),COLOR00FF00;
STICKLINE(C<O,C,O,0,0),COLORFFFFFF;
涨幅:=3.5;
倍量:=1.9;
单阳收:=C;
单阳开:=O;
单阳:=单阳收>=REF(C,1)*(1+阳涨幅/100)AND VOL>REF(VOL,1)*阳倍量;
DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,'阳'),COLOR00FFFF;
高不破价:=REF(C,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
STICKLINE(单阳不破,低不破价-低不破价*0.0005,低不破价,4,0),COLORGREEN;
STICKLINE(单阳不破,高不破价,高不破价,4,0),COLORRED;
STICKLINE(单阳,单阳开,单阳收,2,0),COLORYELLOW;
DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,'1'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,'2'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,'3'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,'4'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,'6'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,'7'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,'9'),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=10 AND 单阳不破,低不破价*0.98,'10'),COLORGREEN;
PP1:=H>=MA(C,5)*(100+8)/100 AND NOT(C/REF(C,1)>1.095);
DRAWICON(PP1,H*1.02,15);
MA2:=MA(C,2);
布林上轨:=MA(CLOSE,20)+2*STD(CLOSE,20);
XG1:=CROSS(MA2,布林上轨);
XG2:=L<=MA(C,26) AND C>=MA(C,26);
XG0:=COUNT(XG1,30)=1 AND XG2 AND FILTER(XG2,10);
DRAWTEXT(XG0,L*0.98,'↖回踩买'),COLORYELLOW;

通达信最新优化组合黄金分割+单阳不破+趋势飘带+买卖点主图指标公式

 

相关文章