在线检测未来函数

通达信龙头判官指标公式

来源:Internet,编辑:股旁网,2015-06-04

INDEXC1:= INDEXC;
YB:= 100;
D1:= 20 * YB * YB * YB;
TMPMAXZF:= IF(PERIOD<5,21,IF(PERIOD=5,10.06 * YB/100,IF(PERIOD=6,63,IF(PERIOD=7,263,IF(PERIOD=9,39,23))))) * YB/100;
TZF_C:= MAX(MIN(IF(BETWEEN(CLOSE/REF(CLOSE,1),0.0001,10000),CLOSE/REF(CLOSE,1) * YB - 100,0),TMPMAXZF),-TMPMAXZF);
TDP_C:= IF((INDEXC1=0) OR (INDEXC1=DRAWNULL),DRAWNULL,INDEXC1/REF(INDEXC1,1) * YB - 100);
HY_INDEXC1:= HY_INDEXC;
HYZF:= HY_INDEXC1/REF(HY_INDEXC1,1) * 100 - YB;
D2:= 14 * YB * YB;
TMP基准:= MAX(MIN(MAX(TDP_C,HYZF),TMPMAXZF * 31/YB),-TMPMAXZF * 31/YB);
TOBJ:= MIN(TZF_C,MAX(MIN(TZF_C - TMP基准,TMPMAXZF),-TMPMAXZF));
TEMP_Q1Q:= SUM(TOBJ * SIGN(D1 + D2 + 521 - (DATE + 1900 * YB * YB)),0);
TEMP_Q1:=TEMP_Q1Q/50;
MA20: MA(TEMP_Q1,MIN(BARSCOUNT(TOBJ) + 1,20)),COLOR00AA00;
MA10: MA(TEMP_Q1,MIN(BARSCOUNT(TOBJ) + 1,10)),COLORMAGENTA,LINETHICK2;
MA5: MA(TEMP_Q1,MIN(TOTALBARSCOUNT - CURRBARSCOUNT + 1,5)),COLORYELLOW;
Q: TEMP_Q1,COLORWHITE;
涨: TZF_C,NODRAW,COLORYELLOW;
说明: DRAWNULL,COLORGREEN;
Q多头就是龙头股: DRAWNULL,COLORRED;
具体看指标说明: DRAWNULL,COLORGREEN;
(价值100万): DRAWNULL,COLORRED;
股旁网: DRAWNULL,NODRAW,COLOR666666;
(龙头判官): DRAWNULL,NODRAW,COLORRED;

通达信龙头判官指标公式

 

相关文章