在线检测未来函数

大智慧碧波白云指标公式

来源:Internet,编辑:股旁网,2015-06-09

DRAWGBKlast(c, strip(RGB(00,255,255) ,RGB(00,00,28),2));{}
g120:=hhv(h,120);
d120:=llv(l,120);
d1:ma(c,144)-3*std(c,89),colorffff00,LINETHICK0;
d2:ma(c,144)-2*std(c,89),colorffff00,LINETHICK0;
d3:ma(c,144)-1.5*std(c,89),colorffff00,LINETHICK0;
d4:ma(c,144)-std(c,89),colorffff00,LINETHICK0;
g1:ma(c,144)+3*std(c,89),colorffff00,LINETHICK0;
g2:ma(c,144)+2*std(c,89),colorffff00,LINETHICK0;
g3:ma(c,144)+1.5*std(c,89),colorffff00,LINETHICK0;
g4:ma(c,144)+std(c,89),colorffff00,LINETHICK0;
z:ema(c,144);
ts:=BARSLAST(CROSS(ema(c,5),z));
ts2:=BARSLAST(CROSS(z,ema(c,5)));
一重天:ref(z+(z-REF(d120,ts)),ts),colorffff00,LINETHICK2;
二重天:ref(z+1.5*(z-REF(d120,ts)),ts),colorffff00,LINETHICK2;
三重天:ref(z+2*(z-REF(d120,ts)),ts),colorffff00,LINETHICK2;
一重海:ref(z-(REF(g120,ts2)-z),ts2),color111111,LINETHICK2;
二重海:ref(z-1.5*(REF(g120,ts2)-z),ts2),color111111,LINETHICK2;
三重海:ref(z-2*(REF(g120,ts2)-z),ts2),color111111,LINETHICK2;
PARTLINE( z,z>ref(z,1),rgb(255,0,0),z<ref(z,1),rgb(0,255,0)),LINETHICK2;
FILLRGN( d1,d2),Color430000,LAYER7;
FILLRGN( d2,d3),Color7F0000,LAYER7;
FILLRGN( d3,d4),ColorAF0000,LAYER7;
FILLRGN( g1,g2),Colorffffff,LAYER7;
FILLRGN( g2,g3),Coloreeeeee,LAYER7;
FILLRGN( g3,g4),Colordddddd,LAYER7;
{FILLRGN( g4,d4),Colorffcc00,LAYER7;}
AaaC:=C;
AaaH:=H;
AaaL:=L;
AaaO:=O;
STICKLINE(AaaC>=AaaO,AaaH,AaaC,1,0),color0000cc;
STICKLINE(AaaC>=AaaO,AaaH,AaaC,0,0),color6633ff;
STICKLINE(AaaC>=AaaO,AaaO,AaaL,1,0),color0000cc;
STICKLINE(AaaC>=AaaO,AaaO,AaaL,0,0),color6633ff;
STICKLINE(AaaC>AaaO,AaaC,AaaO,8,0),COLOR0000cc;
STICKLINE(AaaC>AaaO,AaaC,AaaO,7,0),COLOR3300cc;
STICKLINE(AaaC>AaaO,AaaC,AaaO,6,0),COLOR0033cc;
STICKLINE(AaaC>AaaO,AaaC,AaaO,5,0),COLOR3333cc;
STICKLINE(AaaC>AaaO,AaaC,AaaO,4,0),COLOR0000ff;
STICKLINE(AaaC>AaaO,AaaC,AaaO,3,0),COLOR3300ff;
STICKLINE(AaaC>AaaO,AaaC,AaaO,2,0),COLOR6600ff;
STICKLINE(AaaC>AaaO,AaaC,AaaO,1,0),COLOR6633ff;
STICKLINE(AaaC<=AaaO,AaaH,AaaC,1,0),color888800;
STICKLINE(AaaC<=AaaO,AaaH,AaaC,0,0),colorffff00;
STICKLINE(AaaC<=AaaO,AaaO,AaaL,1,0),color888800;
STICKLINE(AaaC<=AaaO,AaaO,AaaL,0,0),colorffff00;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,8,0),COLOR888800;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,7,0),COLOR999900;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,6,0),COLORaaaa00;
STICKLINE(AaaC<=aaAO,AaaC,AaaO,5,0),COLORbbbb00;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,4,0),COLORcccc00;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,3,0),COLORdddd00;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,2,0),COLOReeee00;
STICKLINE(AaaC<=AaaO,AaaC,AaaO,1,0),COLORffff00;;

大智慧碧波白云指标公式

 

相关文章