在线检测未来函数

大智慧股海波浪主图指标公式

来源:Internet,编辑:股旁网,2015-06-08

a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
生命线:EMA(X,13),colorFF00FF,LINETHICK2;
M:=MA((C+O+H+L)/4,2);
M3:MA(M,3),COLOR8AFAAA;
M5:MA(M3,5),COLORFF00FF;
买入:CROSS(M3,M5),COLORRED;
卖出:CROSS(M5,M3),COLOR00FF00;
{K线修饰}
STICKLINE(M3>=M5,H,L,1,1),COLORRED;
STICKLINE(M3>=M5,OPEN,CLOSE,5,0),COLOR000099;
STICKLINE(M3>=M5,OPEN,CLOSE,3,0),COLOR0000BB;
STICKLINE(M3>=M5,OPEN,CLOSE,1,0),COLOR0000FF;
STICKLINE(M3<M5,H,L,1,1),COLOR00FF00;
STICKLINE(M3<M5,OPEN,CLOSE,5,0),COLOR009900;
STICKLINE(M3<M5,OPEN,CLOSE,3,0),COLOR00BB00;
STICKLINE(M3<M5,OPEN,CLOSE,1,0),COLOR00FF00;
{买入显示}
DRAWTEXT(买入,LOW*0.98,'▲'),COLOR0000FF;
DRAWTEXT(买入,LOW*0.975,'∣'),COLOR0000FF;
DRAWTEXT(买入,LOW*0.975,'‖'),COLOR0000FF;
{买出显示}
DRAWTEXT(卖出,HIGH*1.02,'▼'),COLOR00FF00;
DRAWTEXT(卖出,HIGH*1.025,'∣'),COLOR00FF00;
DRAWTEXT(卖出,HIGH*1.025,'‖'),COLOR00FF00;
{加仓}
加仓:M3>REF(M3,1) AND REF(M3,1)<REF(M3,2) AND M3>M5 AND 买入<>1 AND 卖出<>1,COLORFF00FF;
DRAWTEXT(加仓,LOW*0.98,'▲'),COLORFF00FF;
STICKLINE(加仓,H,L,1,1),COLORFF00FF;
STICKLINE(加仓,OPEN,CLOSE,5,0),COLOR660099;
STICKLINE(加仓,OPEN,CLOSE,3,0),COLOR6600CC;
STICKLINE(加仓,OPEN,CLOSE,1,0),COLORFF00FF;
{减仓}
减仓:M3<REF(M3,1) AND REF(M3,1)>REF(M3,2) AND M3>M5 AND 卖出<>1 AND 买入<>1,COLORYELLOW;
DRAWTEXT(减仓,HIGH*1.02,'▼'),COLORYELLOW;
STICKLINE(减仓,H,L,1,1),COLORYELLOW;
STICKLINE(减仓,OPEN,CLOSE,5,0),COLOR00CCCC;
STICKLINE(减仓,OPEN,CLOSE,3,0),COLOR33FFCC;
STICKLINE(减仓,OPEN,CLOSE,1,0),COLOR00FFFF;
{波浪顶底}
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A2:=REF(C,BARSLAST(HD));
B2A:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
顶:IF(T1,A2,A2),COLOR00FF00,POINTDOT,LINETHICK2;
STICKLINE(T1,A2,A2,9,0),COLOR00FF00;
底:IF(T2,B2A,B2A),COLORFF00FF,POINTDOT,LINETHICK2;
STICKLINE(T2,B2A,B2A,9,0),COLORFF00FF;
【股海方舟】:0,COLORRED;

大智慧股海波浪主图指标公式

 

相关文章