在线检测未来函数

飞狐库存平均能量指标公式

来源:Internet,编辑:股旁网,2015-06-11

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
HY1:=REF(EMA(V1,3),1);
APP:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
ZL:=IF((CLOSE > OPEN),(APP * (HIGH - LOW)),IF((CLOSE < OPEN),(APP * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
SF:=IF((CLOSE > OPEN),(0 - (APP * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (APP * (HIGH - LOW))),(0 - (VOL / 2))));
线性:=((((((CLOSE * 5) + (REF(CLOSE,1) * 4)) + (REF(CLOSE,2) * 3)) + (REF(CLOSE,3) * 2)) + (REF(CLOSE,4) * 1)) / ((((5 + 4) + 3) + 2) + 1));
决策:HY1;
黄色线涨:PARTLINE((CLOSE > HY1),HY1),LINETHICK1,colorFFFF;
青色线跌:PARTLINE((CLOSE <= HY1),HY1),LINETHICK1,colorFFFF00;
DRAWICON(CROSS(CLOSE,HY1),LOW,4);
DRAWICON(CROSS(HY1,CLOSE),HIGH,5);
VAR1:=(((CLOSE - HY1) / HY1) * 100);
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
TS:=BARSLAST((BARSLAST(((VAR1 > 0) AND (REF(VAR1,1) > 0))) > 0));
利润:=SUM(IF((TS > 0),VAR2,0),0);
EXPLAIN(1,'★四方力道决策系统★----www.hytkj.com'),colorFFFF;
EXPLAINEX(HY1,'●决策:',HY1,2,0),colorFF;
EXPLAINEX(线性,'●导航:',线性,2,0),color99CC99;
EXPLAIN(CROSS(CLOSE,HY1),'★状态:参考买进!'),colorFF00FF;
EXPLAIN(CROSS(HY1,CLOSE),'★状态:参考卖出!'),colorFFFF00;
EXPLAIN((CLOSE > HY1),'●状态:关注、买入!'),colorFFFF;
EXPLAIN((CLOSE <= HY1),'●状态:观望、警戒、卖出!'),colorFF00;
EXPLAINEX(利润,'●获利:',利润,2,0),colorFF00FF;
EXPLAINEX(((CLOSE - HY1) * 10),'★多空趋势:',((CLOSE - HY1) * 10),2,1),colorFF00FF;
EXPLAINEX((ZL + SF),'库存能量:',(ZL + SF),2,0),colorFF;
EXPLAINEX(MA((ZL + SF),5),'库存平均:',MA((ZL + SF),5),2,0),colorFF;
EXPLAINEX(ZL,'库存主力:',ZL,2,0),colorFF;
EXPLAINEX(SF,'库存散户:',SF,2,0),colorFF00;
库存能量:ZL + SF;
库存平均:MA((ZL + SF),5);
ema(库存平均,3);

飞狐库存平均能量指标公式

 

相关文章