在线检测未来函数

通达信五型导弹指标公式

来源:Internet,编辑:股旁网,2015-06-16

X5:=EXPMA(CLOSE,3);
X10:=EXPMA(CLOSE,7);
X20:=EXPMA(CLOSE,20);
五日斜率:=(X5-REF(X5,1))*100/REF(X5,1),LINETHICK2,COLORYELLOW;
十日斜率:=(X10-REF(X10,1))*100/REF(X10,1),LINETHICK2,COLORBLUE;
二十斜率:=(X20-REF(X20,1))*100/REF(X20,1),LINETHICK2,COLORWHITE;
XX5:=XMA(五日斜率,4),LINETHICK2,COLORYELLOW;
XX10:=XMA(十日斜率,7),LINETHICK2,COLORBLUE;
XX200:=XMA(二十斜率,20);
AA1:=XX200>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX200
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX200,2) ;
XX202:=XMA(二十斜率,22);
AA2:=XX202>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX202
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX202,2) ;
XX204:=XMA(二十斜率,24);
AA3:=XX204>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX204
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX204,2) ;
XX206:=XMA(二十斜率,26);
AA4:=XX206>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND XX10>XX206
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX206,2) ;
XX207:=XMA(二十斜率,20);
AA7:=XX207>=0.7 AND REF(XX207,1)<XX207 AND CROSS(XX10,XX207)
AND CROSS(REF(XX5,1),REF(XX207,1));
XX2071:=XMA(二十斜率,23);
AA71:=XX2071>=0.7 AND REF(XX2071,1)<XX2071 AND CROSS(XX10,XX2071)
AND CROSS(REF(XX5,1),REF(XX2071,1));
XX2072:=XMA(二十斜率,26);
AA72:=XX2072>=0.7 AND REF(XX2072,1)<XX2072 AND CROSS(XX10,XX2072)
AND CROSS(REF(XX5,1),REF(XX2072,1));
XX208:=XMA(二十斜率,20);
AA8:=XX208>=0.7 AND REF(XX208,1)<XX208 AND CROSS(XX10,XX208)
AND CROSS(XX5,XX208);
XX2081:=XMA(二十斜率,23);
AA81:=XX2081>=0.7 AND REF(XX2081,1)<XX2081 AND CROSS(XX10,XX2081)
AND CROSS(XX5,XX2081);
XX2082:=XMA(二十斜率,26);
AA82:=XX2082>=0.7 AND REF(XX2082,1)<XX2082 AND CROSS(XX10,XX2082)
AND CROSS(XX5,XX2082);
AA?CCJ: IF((AA1 OR AA2 OR AA3 OR AA4 OR AA7 OR AA71 OR AA72 OR AA8 OR AA81
OR AA82)=1,100,0),STICK,COLORMAGENTA,LINETHICK2;
DRAWTEXT(AA1=1,10,'★AA1'),COLORRED;
DRAWTEXT(AA2=1,15,'★AA2'),COLORRED;
DRAWTEXT(AA3=1,20,'★AA3'),COLORRED;
DRAWTEXT(AA4=1,25,'★AA4'),COLORRED;
DRAWTEXT(AA7=1,30,'★AA7'),COLORRED;
DRAWTEXT(AA71=1,35,'★AA71'),COLORRED;
DRAWTEXT(AA72=1,40,'★AA72'),COLORRED;
DRAWTEXT(AA8=1,45,'★AA8'),COLORRED;
DRAWTEXT(AA81=1,50,'★AA81'),COLORRED;
DRAWTEXT(AA82=1,55,'★AA82'),COLORRED;
VARR3:=LLV(HIGH,240);
VARR4:=100*(CLOSE-VARR3)/VARR3;
VARR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VARR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VARR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VARR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VARRA:=BARSCOUNT(CLOSE);
VARRB:=VARR8<20 AND VARR9<23 AND VARRA>35;
VARRC:=VARRB AND COUNT(VARRB,1)=1;
VARRD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARRE:=EMA(VARRD,5);
VARRF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARRD,VARRE);
VARR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VARR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VARR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VARR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VARR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VARR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VARR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VARR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VARR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VARR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VARR1A:=EMA(VARR19,100);
VARR1B:=2*(VARR19-VARR1A);
VARR1C:=POW(VARR1B,3)*0.1+POW(VARR1B,1);
VARR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VARR1E:=EMA(VARR1D*0.97,3);
VARR1F:=(HIGH+LOW+CLOSE)/3;
VARR20:=(VARR1F-MA(VARR1F,14))/(0.015*AVEDEV(VARR1F,14));
VARR21:=CROSS(VARR1E,LOW);
选股买点:VARR10;VARR10=4,0,20,1,0,COLORMAGENTA;
组合买:(VARR11+VARR13+VARR15+VARR17),STICK,COLORRED,LINETHICK2;
IF((VARR11+VARR13+VARR15+VARR17)=1,38,00),STICK,COLORMAGENTA,LINETHICK2;
组合卖: (VARR12+VARR14+VARR16+VARR18),STICK,COLORGREEN,LINETHICK2;
IF((VARR12+VARR14+VARR16+VARR18)=1 ,38,0),STICK,COLORGREEN,LINETHICK2;
IF((VARR12+VARR14+VARR16+VARR18)=2 ,48,0),STICK,COLORGREEN,LINETHICK2;
IF((VARR12+VARR14+VARR16+VARR18)=3 ,58,0),STICK,COLORGREEN,LINETHICK2;
IF((VARR12+VARR14+VARR16+VARR18)=4 ,68,0),STICK,COLORGREEN,LINETHICK2;

通达信五型导弹指标公式

 

相关文章