在线检测未来函数

通达信TOW叠加CCI指标公式

来源:Internet,编辑:股旁网,2015-06-17

ACC:=C;
VAR1:=ACC>REF(ACC,1) AND ACC>REF(ACC,2);
VAR2:=REF(VAR1,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR3:=REF(VAR2,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR4:=REF(VAR3,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR5:=REF(VAR4,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR6:=REF(VAR5,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR7:=REF(VAR6,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR8:=REF(VAR7,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR9:=REF(VAR8,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VARA:=REF(VAR9,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VARB:=REF(VARA,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VARC:=REF(VARB,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR
VAR9 OR VARA OR VARB OR VARC,ACC,REF(ACC,1),2.3,0),COLORRED;
VARD:=ACC<REF(ACC,1) AND ACC<REF(ACC,2);
VARE:=REF(VARD,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VARF:=REF(VARE,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR10:=REF(VARF,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR11:=REF(VAR10,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR12:=REF(VAR11,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR13:=REF(VAR12,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR14:=REF(VAR13,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR15:=REF(VAR14,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR16:=REF(VAR15,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
VAR17:=REF(VAR16,1) AND ACC<=REF(ACC,1) AND ACC>=REF(ACC,2);
VAR18:=REF(VAR17,1) AND ACC>=REF(ACC,1) AND ACC<=REF(ACC,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,ACC,REF(ACC,1),2.3,0),COLORFF9000;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(ACC,1),REF(ACC,2),2.3,0),COLORWHITE;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR
VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(ACC,1),REF(ACC,2),2.3,0),COLOR00FF00;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI数值:=(TYP-MA(TYP,16))/(0.015*AVEDEV(TYP,16)),COLORBLACK;
CCI线: DYNAINFO(3)+DYNAINFO(3)*CCI数值/1000,COLORYELLOW,LINETHICK1;
AAA1:DYNAINFO(3)+DYNAINFO(3)*100/1000,COLORRED,DOTLINE;
CCC1:DYNAINFO(3)+DYNAINFO(3)*(-100)/1000,COLOR00AA00,DOTLINE;

通达信TOW叠加CCI指标公式

 

相关文章