在线检测未来函数

通达信升降买卖点指标公式

来源:Internet,编辑:股旁网,2015-06-23

上升线:EMA(C,3),COLORRED,LINETHICK2;
下降线:EMA(C,5),COLOR00FF00,LINETHICK2;
中间线:EMA(下降线,5),COLORWHITE,LINETHICK2;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA((CLOSE-VAR2),6,1)/SMA(ABS(CLOSE-VAR2),6,1)*100;
VAR4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VAR5:=EMA(0.667*REF(VAR4,1)+0.333*VAR4,5);
VAR6:=IF(VOL>=1.3*MA(VOL,5) AND COUNT(VAR4>=VAR5 AND VAR4<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0);
VAR7:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
VAR8:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
VAR9:=IF(COUNT(VAR8<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWICON(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,2);
DRAWTEXT(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,'快卖'),COLORYELLOW;
DRAWTEXT(FILTER(VAR9 OR VAR6,5),LOW,'注意买入'),COLORRED;
DRAWICON(FILTER(CROSS(上升线,下降线)AND 中间线>=REF(中间线,1)AND VAR3<50,5),上升线,1);

通达信升降买卖点指标公式

 

相关文章