在线检测未来函数

通达信未来买卖指标公式

来源:Internet,编辑:股旁网,2015-06-23

VAR41:=(C-EMA(C,8))/EMA(C,8);
VAR42:=EMA(EMA(VAR41,4),3);
VAR43:=EMA(EMA(VAR41,4),2);
VAR44:100*( VAR42+ VAR43),COLORWHITE,LINETHICK2;
VAR45:EMA(VAR44,2.5),COLORGRAY;
RISE:= VAR44>=REF(VAR44,1);
FELL:= VAR44<REF(VAR44,1);
IF(RISE, VAR44,DRAWNULL),COLORRED,LINETHICK2;
IF(FELL, VAR44,DRAWNULL),COLORGREEN,LINETHICK2;
VAR01:=(INDEXC-EMA(INDEXC,6))/EMA(INDEXC,6);
VAR02:=EMA(EMA(VAR41,3),3);
VAR03:=EMA(EMA(VAR41,3),2);
VAR04:=100*( VAR02+ VAR03);
BI:=100*(H+L)/2/EMA(C,17)-100,COLORYELLOW;
BUY1:=VAR44>REF(VAR44,1) AND REF(VAR44,1)<REF(VAR44,2) AND REF(VAR44,2)<REF(VAR44,3);
BUY2:=REF(BI,1)>0 AND BUY1 AND VAR44<-2;
BUY3:=REF(BI,1)<0 AND BUY1 AND REF(VAR44,1)<-3;
BUY4:=VAR44<0 AND CROSS(VAR44,VAR45) AND BUY1;
BUY:=(BUY2 OR BUY3 OR BUY4) AND (EMA(INDEXC,6)>REF(EMA(INDEXC,6),1) OR VAR04>=REF
(VAR04,1));
DRAWICON(BUY,VAR44-1.1,1);

通达信未来买卖指标公式

 

相关文章