在线检测未来函数

飞狐满仓底线均线指标公式

来源:Internet,编辑:股旁网,2015-06-24

input:N(3,1,10),N2(6,1,10),N3(-23,-50,0),N4(75,50,100),P1(19,1,100),P2(118,1,250),N1(9,1,100);
DRAWGBK(CLOSE,COLORRGB(10,160,0),COLORRGB(25,15,0),1);
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:((3 * VAR4) - (2 * VAR5));
VAR6:=(J > (1 * REF(J,1)));
VAR7:=LLVBARS(LOW,50);
VAR8:=SUM(VOL,VAR7);
VAR9:=HHVBARS(HIGH,50);
VAR10:=SUM(VOL,VAR9);
VAR11:=(((CLOSE - REF(OPEN,VAR9)) / REF(OPEN,VAR9)) * 100);
VAR12:=((VAR10 / CAPITAL) * 100);
VAR13:=(((CLOSE - REF(OPEN,VAR7)) / REF(OPEN,VAR7)) * 100);
VAR14:=((VAR8 / CAPITAL) * 100);
VAR15:=(MA(WINNER(CLOSE),N) * 100);
VAR16:=EMA(VAR4,N);
A2:EMA(VAR4,N),colorFFDDCC;
A3:=EMA(A2,N);
A4:=EMA(A3,N);
A5:=EMA(A4,N);
A6:=EMA(A5,N);
A7:=EMA(A6,N);
VAR17:=EMA(A7,N);
VAR18:=EMA(VAR17,N);
VAR19:=EMA(VAR18,N);
AA:=EMA(A5,N2);
中期大底:LLV(J,AA),LINETHICK2,colorFF;
上:=((FFT((MA(HIGH,3) * 1.05),30) * 10) - AA);
下:=((FFT((MA(LOW,3) * 0.96),30) * 2) / 中期大底);
上上:=FFT((MA(HIGH,3) * 1.05),30);
电:=J;
DRAWTEXT((CROSS(A4,AA) AND (VAR11 < N3)),AA,'●底'),colorFF00;
DRAWTEXT((CROSS(A2,J) AND (A2 > N4)),(A2 + 4.04),'●峰'),colorFFFF;
DRAWTEXT(((((CROSS(J,A2) AND VAR6) AND (A2 < 20)) AND (VAR2 > 9)) OR (((A2 > (1 * REF(A2,1))) AND (VAR2 > 4)) AND (A2 < 60))),A2,'●拉'),colorFFFFCC;
FILLRGN((J >= A2),A2,J),colorFF;
FILLRGN((J <= A2),J,A2),colorFF00;
压力:HHV(J,60),colorFFFF;
支撑:=LLV(AA,13);
STICKLINE((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),1,88,3,0),colorFF00;
DRAWICON((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),88,0);
DRAWTEXT((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),85,'-绝对底部');
STICKLINE(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),中期大底,70,3,0),colorFF;
DRAWICON(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),70,0);
DRAWTEXT(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),64,'-买了不输'),colorFFFFFF;
STICKLINE((CROSS(上,下) AND (CLOSE >= OPEN)),中期大底,60,2,0),colorFF0000;
DRAWICON((CROSS(上,下) AND (CLOSE >= OPEN)),60,0);
DRAWTEXT((CROSS(上,下) AND (CLOSE >= OPEN)),55,'-短线');
DRAWTEXT((((J >= 压力) AND ((压力 - REF(压力,6)) > 25)) AND (CLOSE < OPEN)),(压力 + 4.22),'●头部'),colorFF00;
MA1:=MA(CLOSE,P1);
MA2:=MA(CLOSE,P2);
N15HIGH:=REF(HIGH,15);
N1LOW:=REF(LOW,1);
FF:=(((N15HIGH - N1LOW) / N1LOW) > 0.15);
STICKLINE((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),中期大底,60,0,1),LINETHICK3,colorFF;
DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),60,1);
DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH - N1LOW) / N1LOW) < 0.15)) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),60,'★^回头望月'),colorFF0000;
X:=(CLOSE - REF(MA(CLOSE,20),11));
LGL:=IF((((((EMA(CLOSE,5) / EMA(EMA(CLOSE,9),16)) <= 0.85) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
WR1:=((0 - ((100 * (HHV(HIGH,34) - CLOSE)) / (HHV(HIGH,34) - LLV(LOW,34)))) + (100 * X));
WR2:=((0 - ((100 * (HHV(HIGH,50) - CLOSE)) / (HHV(HIGH,50) - LLV(LOW,50)))) + 100);
WR3:=((0 - ((100 * (HHV(HIGH,70) - CLOSE)) / (HHV(HIGH,70) - LLV(LOW,70)))) + (100 * X));
BIAS1:=(((((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * 100) + 10) * 5);
BIAS2:=(((((CLOSE - MA(CLOSE,50)) / MA(CLOSE,50)) * 100) + 10) * 5);
BIAS3:=(((((CLOSE - MA(CLOSE,70)) / MA(CLOSE,70)) * 100) + 10) * 5);
S1:=(((((((WR1 + WR2) + WR3) + BIAS1) + BIAS2) + BIAS3) / 6) * X);
S2:=EMA(S1,3);
S3:=ABS((BIAS1 - BIAS3));
SX:=((S1 + S3) / 2);
XC1:=(((0 - 1) * (EMA((100 * (1 - WINNER(CLOSE))),1) - 50)) + 50);
CCC:=(XC1 + SX);
ZJZ:=(IF(((LGL > 0) AND (CCC < 0)),200,0) * X);
LXL:=IF((((((SX < 0) AND (CLOSE = LLV(CLOSE,5))) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),(0 - 50),0);
JBJ:=(IF(((CCC < 0) AND (LXL = (0 - 50))),100,0) * X);
MA3:=MA(CLOSE,3);
C0:=(REF(CLOSE,2) * 0.865);
C1:=(REF(CLOSE,13) * 0.772);
BOT:=MIN(C0,C1);
HSL:=(((100 * VOL) / CAPITAL) * X);
MA13:=(MA(CLOSE,13) * X);
CXC:=IF(((((CLOSE - BOT) / CLOSE) < (3 / 100)) AND ((SUM(HSL,5) / 5) < 1.8)),1,0);
VMC:=IF(((CXC > 0) AND ((LXL < 0) OR (LGL > 0))),10,0);
满仓:IF((VMC > 0),60,中期大底),colorFF;
DRAWTEXT((满仓 >= 60),59,'-满仓'),colorFF;
半仓:IF((((((ZJZ > 0) AND (JBJ > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR ((CXC > 0) AND ((REF(CLOSE,1) / REF(CLOSE,2)) > 0.902))) OR ((((((ZJZ > 0) AND (JBJ > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR (CXC > 0)) AND ((LXL < 0) OR (LGL > 0))) AND (VMC < 10))),50,中期大底),colorCC99FF;
DRAWTEXT((半仓 >= 50),49,'-半仓'),colorCC99FF;
B0:=MA(CLOSE,3);
B01:=MA(CLOSE,4);
B1:=(((HIGH + LOW) + CLOSE) / 3);
B2:=HHV(B1,15);
B3:=LLV(B1,15);
B4:=(B2 - B3);
B5:(MA(((B1 - B3) / B4),2) * 100),COLORMAGENTA;
B6:=HHV(B1,(4 * 15));
B7:=LLV(B1,(4 * 15));
B8:=(B6 - B7);
B9:(MA(((B1 - B7) / B8),2) * 100);
BA:=HHV(B1,(16 * 15));
BB:=LLV(B1,(16 * 15));
BC:=(BA - BB);
BD:(MA(((B1 - BB) / BC),2) * 100);
顶线:98;
底线:1;
STICKLINE((((CROSS(B5,底线) AND ((B0 - REF(B0,1)) > 0)) AND ((J - REF(J,1)) > 0)) AND (CLOSE >= OPEN)),中期大底,50,2,0),colorFF;
DRAWICON((((CROSS(B5,底线) AND ((B0 - REF(B0,1)) > 0)) AND ((J - REF(J,1)) > 0)) AND (CLOSE >= OPEN)),50,0);
DRAWTEXT((((CROSS(B5,底线) AND ((B0 - REF(B0,1)) > 0)) AND ((J - REF(J,1)) > 0)) AND (CLOSE >= OPEN)),45,'-开花一'),colorCC99FF;
STICKLINE(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 - REF(B01,1)) > 0)),中期大底,64,2,0),colorFF00;
DRAWICON(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 - REF(B01,1)) > 0)),64,0);
DRAWTEXT(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 - REF(B01,1)) > 0)),58,'-开花二');
DRAWTEXT((CROSS(98,B5) AND (CLOSE < (HIGH / 1.03))),98,'-出局'),colorFF00;
DRAWICON((CROSS(98,B5) AND (CLOSE < (HIGH / 1.03))),98,7);
STICKLINE(((CROSS(BD,1) AND ((上上 - REF(上上,1)) > 0)) AND ((B5 - REF(B5,2)) > 0)),1,80,3,0);
DRAWICON(((CROSS(BD,1) AND ((上上 - REF(上上,1)) > 0)) AND ((B5 - REF(B5,2)) > 0)),80,0);
DRAWTEXT(((CROSS(BD,1) AND ((上上 - REF(上上,1)) > 0)) AND ((B5 - REF(B5,2)) > 0)),73,'-开花三'),colorFFFF;
STICKLINE(((((CROSS(J,AA) AND (A2 >= A3)) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= OPEN)) AND (A3 >= A4)),中期大底,60,2,0),colorFFFFFF;
DRAWTEXT(((((CROSS(J,AA) AND (A2 >= A3)) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= OPEN)) AND (A3 >= A4)),60,'●买'),colorFFFF;
均线:=MA(CLOSE,5);
DRAWICON(((CROSS(B5,A2) AND ((上上 - REF(上上,1)) > 0)) AND ((均线 - REF(均线,1)) > 0)),98,6);
DRAWTEXT(((CROSS(B5,A2) AND ((上上 - REF(上上,1)) > 0)) AND ((均线 - REF(均线,1)) > 0)),98,' 关注'),colorFF;
VARW2:=((((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100) AND ((上上 - REF(上上,1)) > 0));
VARW3:=((((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100) AND ((上上 - REF(上上,1)) > 0));
VARW4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARW5:=(((VARW2 + (2 * VARW3)) + (3 * VARW4)) / 6);
VARW6:=MA(VARW5,3);
犀牛王:((70 * VARW6) <= (0 - 8));

飞狐满仓底线均线指标公式

 

相关文章