在线检测未来函数

通达信波段看盘指标公式

来源:Internet,编辑:股旁网,2015-06-24

N:=60;
A1:30,COLORWHITE,LINETHICK1;
A2:50,COLORGREEN;
A3:60,COLORFF0080,LINETHICK1;
A4:70,POINTDOT,LINETHICK1;
A5:80,COLORRED,LINETHICK1;
{主力轨迹}
VAR1Y:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=EMA(ABV,12);
M2:=EMA(ABV,26);
MTM:=CLOSE-REF(CLOSE,1);
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
MTGJ:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);
MAZL:=MA(ZLGJ,5);
A:=((VOL)/(CAPITAL))*(100);
S1:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));
Y1:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));
X1:=1;
V1:=(HIGH+OPEN+LOW+(2)*(CLOSE))/(5);
V2:=REF(V1,1);
V3:=MAX(V1-V2,0);
V4:=ABS(V1-V2);
V5:=SMA(V3,10,1);
V6:=SMA(V4,10,1);
V8:=COUNT(((V5)/(V6)<0.2),5);
V9:=COUNT((LLV(V1,10)=V1),10);
主力进出:IF((MMS>REF(MMS,1) AND ZLGJ>REF(ZLGJ,1) AND CROSS(ABV,M2) AND ABV>REF(ABV,1) AND M1>REF(M1,1) AND M2>REF(M2,1)),65,0),COLORWHITE,POINTDOT;
主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(ZLGJ,MAZL);
STICKLINE(主力进出 OR 主进主轨,35,0,1,1),COLORWHITE;
精准买卖:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND MMS>MML AND CROSS(ABV,M2);
短线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND CROSS(MMS,MML) AND ABV>REF(ABV,1);
中线买点:=V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND (VOL>REF(VOL,1)) AND ABV>REF(ABV,1) AND MMS>MML AND CROSS(MMM,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
主进主买:=ABV>M2 AND ZLGJ>MAZL AND CROSS(MMS,MML) AND MMS>REF(MMS,1) AND MMM>REF(MMM,1) AND MML>REF(MML,1);
短中精:=精准买卖 OR 短线买点 OR 中线买点 OR 主进主买;
主力买卖:IF(短中精,60,0),COLORFF00FF,POINTDOT;
STICKLINE(主力买卖,30,0,1,0),COLORFF00FF;
主力轨迹:IF(ABV>M2 AND MMS>MML AND CROSS(ZLGJ,MAZL) AND ZLGJ>REF(ZLGJ,1) AND MAZL>REF(MAZL,1),55,0),COLORFFCC66,POINTDOT;
STICKLINE(主力轨迹,25,0,1,0),COLORFFCC66;
拉升在即:IF(S1<X1 AND Y1<X1 AND MMS>MML AND ABV>M1 AND CROSS(S1,Y1),50,0),COLORYELLOW,POINTDOT;
STICKLINE(拉升在即,20,0,1,0),COLORYELLOW;
冲击波:IF(CROSS(ROC,16) AND HSL>3.5,40,0),COLOR0099FF,POINTDOT;
STICKLINE(冲击波,10,0,1,0),COLOR0099FF;
底部构成:IF(V8>=1 AND V9>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1) AND ABV>M2 AND ZLGJ>MAZL,45,0),COLOR00FF00,POINTDOT;
STICKLINE(底部构成,15,0,1,0),COLOR00FF00;
ROC:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;
HSL:=100*VOL/CAPITAL;
{中长波段王}
{参数N:40 100 60}
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
AA:= VARA*2;
BB:= EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
CC:= SMA(VAR5,20,1);
VARD:=SMA(AA,2,1)-AA;
VARE:=EMA(0.667*REF(BB,1)+0.333*BB,2)-BB;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
S:=IF(VAR6A>N,VAR6A-N,0),DOTLINE,COLORGRAY;
STICKLINE(CC-SMA(CC,5,1)>0,CC,SMA(CC,5,1),4,1),COLORYELLOW;
STICKLINE(CC-SMA(CC,5,1)<0,CC,SMA(CC,5,1),4,1),COLORLIBLUE;
STICKLINE(BB-VARC>0,BB,VARC,2,0),COLORRED;
STICKLINE(BB-VARC<0,BB,VARC,2,0),COLORGREEN;
{STICKLINE(REF(S,1)>S,S,REF(S,1),2,0),COLORFFCC66;};
{庄家轨迹}
A2Z:=(5);
A3Z:=(((2*CLOSE)+HIGH)+LOW)/4;
A4Z:=LLV(LOW,34);
A5Z:=HHV(HIGH,34);
A6Z:=EMA((((A3Z-A4Z)/(A5Z-A4Z))*100),13);
A7Z:=(EMA(((0.667*(REF(A6Z,1)))+(0.333*A6Z)),2));
庄家轨迹:(EMA(A7Z,A2Z)),COLORRED;
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
DRAWICON((A28 OR A31),庄家轨迹,26);
DRAWTEXT((A28 OR A31),庄家轨迹,'←启动'),COLORWHITE;
{量能监测}
Y:=(H+O+L+3*C)/6;
X:EMA(100-(100/(1+SUM(IF(Y>REF(Y,1),Y*VOL,0),13)/SUM(IF(Y<REF(Y,1),Y*VOL,0),13))),5),COLORWHITE,LINETHICK1;
AA1:=30>X,LINETHICK0;
BB1:=X>80,LINETHICK0;
STICKLINE(AA1,A1,A1*0.9,1,0),COLORRED;
{DRAWTEXT(AA1,A1*0.9,'吸'),COLOR0066FF;
DRAWTEXT(AA1,A1*0.84,'货'),COLOR0066FF;}
STICKLINE(BB1,A5,A5*1.03,0.1,0),COLORGREEN;
{DRAWTEXT(BB1,A5*1,'派'),COLORFFFF00;
DRAWTEXT(BB1,A5*0.96,'发'),COLORFFFF00;};

通达信波段看盘指标公式

 

相关文章