在线检测未来函数

通达信银K线主图指标公式

来源:Internet,编辑:股旁网,2015-06-26

ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停}
YM:EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),COLORRED,LINETHICK1;
YM1:=EMA(YM,5),COLORRED,LINETHICK1;
YM2:=EMA(YM1,5),COLORRED,LINETHICK1;
IF(YM>=YM2,YM,DRAWNULL),LINETHICK1,COLORRED;
IF(YM>=YM2,YM1,DRAWNULL),LINETHICK1,COLORRED;
IF(YM<=YM2,YM,DRAWNULL),LINETHICK1,COLORGREEN;
IF(YM<=YM2,YM1,DRAWNULL),LINETHICK1,COLORGREEN;
IF(YM>=YM2,YM,DRAWNULL),LINETHICK1,COLORRED;
YM3:EMA((CLOSE+HIGH+LOW)/3,3),COLORGREEN;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)>=YM,LOW,HIGH,0,0),COLORRED;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)>=YM,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)<=YM,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(EMA((CLOSE+HIGH+LOW)/3,3)<=YM,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(YM>=YM2 AND YM3<=YM,LOW,HIGH,0,0),COLORBLUE;
STICKLINE(YM>=YM2 AND YM3<=YM,O,C,3,0),COLORBLUE;
STICKLINE(YM>=YM2 AND YM3<=YM ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(YM>=YM2 AND YM3<=YM,OPEN,CLOSE,3.1,0 ),COLOR555555;
STICKLINE(YM>=YM2 AND YM3<=YM ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(YM>=YM2 AND YM3<=YM ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(YM>=YM2 AND YM3<=YM ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(YM>=YM2 AND YM3<=YM ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(YM>=YM2 AND YM3<=YM ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
DRAWTEXT(YM>=YM2 AND YM3<=YM AND ZT,L,'【精准导弹】'),COLORYELLOW;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT,CLOSE,OPEN,3.2,0),COLOR0077FF;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT,CLOSE,OPEN,2.5,0),COLOR0099FF;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT,CLOSE,OPEN,0.3,0),COLOR00FFFF;
STICKLINE(YM>=YM2 AND YM3<=YM AND ZT AND C>O,O,C,0.1,0),COLORFFFFFF;
VAR21:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR22:=8;
QQ:=CROSS(VAR21,VAR22);
STICKLINE(QQ AND YM>=YM2 AND YM3<=YM,C,O,5,2),COLORYELLOW{98FD};
STICKLINE(QQ AND YM>=YM2 AND YM3<=YM,C,O,3,0),COLOR00C8FF;
STICKLINE(QQ AND YM>=YM2 AND YM3<=YM,C,O,2,0),COLOR10ECFF;
STICKLINE(QQ AND YM>=YM2 AND YM3<=YM,C,O,2,0),COLOR10FFFF;
DRAWTEXT(QQ AND YM>=YM2 AND YM3<=YM,L*0.98,'短入'),COLOR0099FF;
大单动向:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7);
涨跌动因:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
大单比:=(超B+大B+中B)/(超S+大S+中S);
资金定位:=大单动向>0.02 AND 涨跌动因>5 AND 大单比>1;
MACD价格1:=EMA(CLOSE,3) - EMA(CLOSE,9);
DEA1021:=EMA((EMA(MACD价格1,102) - EMA(MACD价格1,204)),9);
DEA511:=EMA((EMA(MACD价格1,51) - EMA(MACD价格1,102)),9);
DEA36361:=EMA((EMA(MACD价格1,36) - EMA(MACD价格1,72)),9);
DEA24241:=EMA((EMA(MACD价格1,24) - EMA(MACD价格1,48)),9);
DEA18181:=EMA((EMA(MACD价格1,18) - EMA(MACD价格1,36)),9);
DEA661:=EMA((EMA(MACD价格1,6) - EMA(MACD价格1,12)),9);
DEA331:=EMA((EMA(MACD价格1,3) - EMA(MACD价格1,9)),9);
DEA12121:=EMA((EMA(MACD价格1,12) - EMA(MACD价格1,24)),9);
MACD24241:=2*((EMA(MACD价格1,24) - EMA(MACD价格1,48))-DEA24241);
HH1:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL1:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H1:=EMA(HH1,90),COLORRED,LINETHICK1;
D90L1:=EMA(LL1,90),COLORRED,LINETHICK1;
D901:=(D90H1+D90L1)/2;
Y1M:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48);
CCI151:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,15))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,15));
CCI101:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,10))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,10));
CCI51:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));
CCI31:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,3))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,3));
CCI买点定位1:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI151,1)>0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位2:=CROSS(CCI31,0) AND CCI51>REF(CCI51,1) AND REF(CCI51,1)<-100 AND REF(CCI151,1)>0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位3:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI101,1)>0 AND REF(CCI101,1)>REF(CCI151,1);
CCI买点定位:=CCI买点定位1=1 OR CCI买点定位2=1 OR CCI买点定位3=1;
起爆金股1:=CCI买点定位=1 AND DEA12121>DEA18181 AND DEA18181>DEA24241 AND DEA24241>DEA36361 AND DEA36361>DEA511 AND DEA511>=DEA1021 AND DEA18181>REF(DEA18181,1) AND DEA24241>REF(DEA24241,1) AND DEA36361>REF(DEA36361,1) AND DEA511>REF(DEA511,1) AND DEA1021>REF(DEA1021,1) AND DEA36361>0 AND DEA331>0;
起爆金股2:=CCI买点定位=1 AND DEA12121>DEA18181 AND DEA18181>DEA24241 AND DEA24241>DEA36361 AND DEA18181>DEA1021 AND DEA18181>REF(DEA18181,1) AND DEA24241>REF(DEA24241,1) AND DEA36361>REF(DEA36361,1) AND DEA511>REF(DEA511,1) AND DEA1021>REF(DEA1021,1) AND DEA18181>0 AND DEA331>0;
起爆金股:=起爆金股1=1 OR 起爆金股2=1;
VOL比:=VOL/REF(VOL,1);
高度1:=(D90H1-D90L1)*4+D90H1;
PBX11:=(EXPMA((CLOSE+HIGH+LOW)/3,4)+EMA((CLOSE+HIGH+LOW)/3,4*2)+EMA((CLOSE+HIGH+LOW)/3,4*4))/3;
PBX22:=(EXPMA((CLOSE+HIGH+LOW)/3,5)+EMA((CLOSE+HIGH+LOW)/3,5*2)+EMA((CLOSE+HIGH+LOW)/3,5*4))/3;
PBXHH:=(EXPMA(H,2)+EMA(H,2*2)+EMA(H,2*4))/3,COLORGREEN,LINETHICK1;
PBXLL:=(EXPMA(L,2)+EMA(L,2*2)+EMA(L,2*4))/3,COLORRED,LINETHICK1;
PBX高:=REF(PBXHH,1),COLORGREEN,LINETHICK1;
PBX低:=REF(PBXLL,1),COLORRED,LINETHICK1;
PMX差:=PBX高-PBX低;
起爆止盈价:=PBX高+PMX差*2,COLORWHITE,LINETHICK1;
起爆获利率:=(起爆止盈价-PBX高)/PBX高*100;
起爆止损价:=PBX低-PMX差*0.7,COLORWHITE,LINETHICK1;
起爆止损率:=(起爆止损价-PBX高)/PBX高*100;
海底蛟龙:=(CLOSE+HIGH+LOW)/3<D901 AND (CLOSE+HIGH+LOW)/3>Y1M AND 起爆金股=1 AND C<高度1 AND PBX11>PBX22 AND L<PBX高 AND O<PBX高 AND 资金定位=1 AND VOL比>1.2;
云上天龙:=(CLOSE+HIGH+LOW)/3>D901 AND (CLOSE+HIGH+LOW)/3>Y1M AND 起爆金股=1 AND C<高度1 AND PBX11>PBX22 AND L<PBX高 AND O<PBX高 AND 资金定位=1 AND VOL比>1.2;
起爆点:=海底蛟龙=1 OR 云上天龙=1;
STICKLINE(起爆点=1 AND C<PBX高,LOW,HIGH,0,0),COLORYELLOW;
STICKLINE(起爆点=1 AND C<PBX高,CLOSE,OPEN,3,0),COLORYELLOW;
STICKLINE(起爆点=1 AND C>PBX高,LOW,PBX高,0,0),COLORYELLOW;
STICKLINE(起爆点=1 AND C>PBX高,PBX高,OPEN,3,0),COLORYELLOW;
DRAWICON(起爆点=1,L,1);

通达信银K线主图指标公式

 

相关文章