在线检测未来函数

通达信拉升顶底背离主图指标公式

来源:Internet,编辑:股旁网,2015-07-01

MA13:=MA(CLOSE,13);
X1:=(CLOSE+LOW+HIGH)/(3);
BB13:=((ATAN(EMA(X1,13)-REF(EMA(X1,13),1)))*(3.1416))*(10);
EMA8:=EMA(CLOSE,8);
DRAWTEXT(FILTER((BB13>1) AND (EMA(X1,13)>REF(EMA(X1,8),1)),10),EMA8,'∠45上升'),CoLorFFFFFF;
压力:MA(REF(HHV(CLOSE,30),1),2),CoLor9DFFFF;
支撑:MA(REF(LLV(CLOSE,30),1),2),CoLorABFF46;
AA1:=(AMOUNT)/(VOL);
BB1:=(LOW<(AA1)*(0.9));{本文来源:'www.028588.com' }
CC1:=(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100)>1.2);
DD1:=(LOW<(MA(CLOSE,5))*(0.921));
EE1:=(VOL<(MA(VOL,5))*(1.5));
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW)*(0.96),'老鼠仓'),CoLor4080FF;
A51:=(3)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1))-(2)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1));
黑马线:=EMA(A51,5);
A54:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
趋势线:=MA((3)*(SMA(A54,6,1))-(2)*(SMA(SMA(A54,5,1),5,1)),2);
DRAWTEXT(CROSS(趋势线,0) AND (黑马线<40),(LOW)*(0.96),'▲大黑马'),CoLor00FFFF;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1)))*(100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW)*(0.96),'底背离'),CoLorA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH)*(1.04),'顶背离'),CoLor1880FF;
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=(EMA(((CLOSE-VAR2)/(VAR3-VAR2))*(4),4))*(25);
注意买:=IF((VAR4<10),80,100);
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=(3)*(K)-(2)*(D);
超跌:=IF((J<0),10,0);
BDDD:=(LLV(J,2)=LLV(J,8));
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND (J<20),30,0);
DRAWTEXT(买入 AND (注意买=100) AND (超跌=0),(LOW)*(0.96),'短线'),CoLor8000FF;
MTM:=CLOSE-REF(CLOSE,1);
DX:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
买:=IF((LLV(DX,2)=LLV(DX,7)) AND COUNT((DX<0),2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER((买=1),5),(LOW)*(0.96),'拉升'),CoLorFFDE00;
STICKLINE((CLOSE>REF(CLOSE,1)),HIGH,LOW,0,1),CoLor0000FF;
STICKLINE((CLOSE>REF(CLOSE,1)),OPEN,CLOSE,8,0),CoLor000055;
STICKLINE((CLOSE=REF(CLOSE,1)),HIGH,LOW,0,1),CoLorFFFFFF;
STICKLINE((CLOSE=REF(CLOSE,1)),OPEN,CLOSE,8,1),CoLor333333;
STICKLINE((CLOSE<REF(CLOSE,1)),HIGH,LOW,0,1),CoLorFFFF00;
STICKLINE((CLOSE<REF(CLOSE,1)),OPEN,CLOSE,8,0),CoLorFF0033;
STICKLINE((CLOSE>OPEN),OPEN,LOW,0.5,0),CoLor0000FF;
STICKLINE((CLOSE>OPEN),CLOSE,HIGH,0.5,0),CoLor0000FF;
STICKLINE((OPEN>=CLOSE),CLOSE,LOW,0.5,0),CoLor00FF00;
STICKLINE((OPEN>=CLOSE),OPEN,HIGH,0.5,0),CoLor00FF00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,7,0),CoLorFF7700;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,6,0),CoLorFF9900;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,5,0),CoLorFFBB00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,4,0),CoLorFFCC00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,3,0),CoLorFFDD00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,2,0),CoLorFFEE00;
STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,1,0),CoLorFFFF00;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,7,0),CoLor000055;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,6,0),CoLor000066;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,5,0),CoLor000077;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,4,0),CoLor000099;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,3,0),CoLor0000BB;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,2,0),CoLor0000DD;
STICKLINE((CLOSE>OPEN),CLOSE,OPEN,1,0),CoLor0000FF;
VAR9Q:=((((CLOSE=HHV(CLOSE,4)) AND ((REF(CLOSE,1)>=REF(CLOSE,2)) or (REF(CLOSE,1)>=REF(CLOSE,3))) or (REF(CLOSE,1)=HHV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,2))) or (REF(CLOSE,2)=HHV(CLOSE,4)) AND (REF(CLOSE,3)=LLV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1))) or (REF(CLOSE,3)=HHV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1)) AND (CLOSE>=REF(CLOSE,2)));
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),7,0),CoLor000055;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),6,0),CoLor000066;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),5,0),CoLor000077;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),4,0),CoLor000099;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),3,0),CoLor0000BB;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),2,0),CoLor0000DD;
STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),1,0),CoLor0000FF;
VARAQ:=(CLOSE=HHV(CLOSE,4)) AND (REF(CLOSE,1)=LLV(CLOSE,4));
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),7,0),CoLorFF11FF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),6,0),CoLorFF33FF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),5,0),CoLorFF55FF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),4,0),CoLorFF77FF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),3,0),CoLorFF99FF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),2,0),CoLorFFBBFF;
STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),1,0),CoLorFFDDFF;
VARBQ:=((((CLOSE=LLV(CLOSE,4)) AND ((REF(CLOSE,1)<REF(CLOSE,2)) or (REF(CLOSE,1)<REF(CLOSE,3))) or (REF(CLOSE,1)=LLV(CLOSE,4)) AND (CLOSE<REF(CLOSE,2))) or (REF(CLOSE,2)=LLV(CLOSE,4)) AND (REF(CLOSE,1)<>HHV(CLOSE,4)) AND (CLOSE<REF(CLOSE,1))) or (REF(CLOSE,3)=LLV(CLOSE,4)) AND (CLOSE<REF(CLOSE,1)) AND (CLOSE<REF(CLOSE,2)));
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),7,0),CoLor333333;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),6,0),CoLor555555;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),5,0),CoLor777777;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),4,0),CoLor999999;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),3,0),CoLorBBBBBB;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),2,0),CoLorDDDDDD;
STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/(2),1,0),CoLorFFFFFF;
VARCQ:=((REF(CLOSE,1)=LLV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,2)) or (REF(CLOSE,2)=LLV(CLOSE,4)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<REF(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1)));
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),7,0),CoLor003300;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),6,0),CoLor005500;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),5,0),CoLor007700;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),4,0),CoLor009900;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),3,0),CoLor00BB00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),2,0),CoLor00DD00;
STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),1,0),CoLor00FF00;
VARDQ:=((REF(CLOSE,1)=HHV(CLOSE,4)) AND (CLOSE<REF(CLOSE,2)) or ((REF(CLOSE,2)=HHV(CLOSE,4)) AND (REF(CLOSE,1)>REF(CLOSE,3)) or (REF(CLOSE,3)=HHV(CLOSE,4)) AND (REF(CLOSE,1)>REF(CLOSE,2))) AND (REF(CLOSE,2)>=REF(CLOSE,4)) AND (CLOSE<REF(CLOSE,1)));
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),7,0),CoLorFF1100;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),6,0),CoLorFF3300;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),5,0),CoLorFF5500;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),4,0),CoLorFF7700;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),3,0),CoLorFF9900;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),2,0),CoLorFFBB00;
STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/(2),1,0),CoLorFFDD00;

通达信拉升顶底背离主图指标公式

 

相关文章