在线检测未来函数

通达信超级波段幻影主图指标公式

来源:Internet,编辑:股旁网,2015-07-01

EMA(EMA(HIGH,5),15)*1.14,pointdot;
EMA(EMA(LOW,5),10)*0.94,pointdot;
EMA(EMA(HIGH,5),15)*1.24,pointdot;
EMA(EMA(LOW,5),10)*0.84,pointdot;
多空线: (MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,colorwhite;
Var1:=EMA(CLOSE,7);
Var2:=EMA(CLOSE,21);
Var3:=EMA(Var2,7);
Var4:=EMA(Var3,27);
Var5:=EMA(Var2,100);
Var6:=EMA(Var5,100);
Var7:=MA(CLOSE,5);
Var8:=Var1>Var2 AND Var2>Var3 AND Var3>Var4 AND Var4>Var5 AND Var5>Var6;
Var9:=Var2>REF(Var2,1) AND Var3>REF(Var3,1) AND Var4>REF(Var4,1) AND Var5>REF(Var5,1)
AND Var6>REF(Var6,1);
VarA:=(LOW+HIGH+CLOSE+OPEN)/4;
VarB:=MA(CLOSE,34);
VarC:=MA(CLOSE,60);
VarD:=(2*CLOSE+HIGH+LOW)/4;
VarE:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VarF:=EMA(VarE,7);
Var10:=LLV(LOW,34);
Var11:=HHV(HIGH,34);
Var12:=EMA((VarD-Var10)/(Var11-Var10)*100,6);
Var13:=EMA(0.667*REF(Var12,1)+0.333*Var12,4);
Var14:=LLV(LOW,120);
Var15:=HHV(HIGH,120);
Var16:=Var15-Var14;
Var17:=REF(CLOSE,1);
Var18:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
Var19:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
Var1A:=SMA(MAX(CLOSE-Var17,0),6,1)/SMA(ABS(CLOSE-Var17),6,1)*100;
Var1B:=MA(VarA,5);
Var1C:=HHV(Var1B,20);
Var1D:=HHV(Var1B,60);
Var1E:=LLV(Var1B,20);
Var1F:=FORCAST(CLOSE,10);
Var20:=EMA(Var1F*1.05,3);
Var21:=EMA(Var1F*0.95,4);
Var22:=100*(CLOSE-Var21)/(Var20-Var21);
DRAWTEXT(Var19+Var18<7 AND CROSS(VarE,VarF) AND VarF<-18 AND
VarF<Var18,LOW+0.8,'●'),colorred;
DRAWTEXT(Var19+Var18<7 AND CROSS(VarE,VarF) AND VarF<-18 AND VarF<Var18,LOW+1.07,'短
买'),colorred;
DRAWTEXT(FILTER(Var9 AND Var8 AND COUNT(Var1<REF(Var1,1),5)>2 AND Var1>REF
(Var1,1),3),LOW-0.2,'●'),colorff00ff;
DRAWTEXT(FILTER(Var9 AND Var8 AND COUNT(Var1<REF(Var1,1),5)>2 AND Var1>REF
(Var1,1),3),LOW+0.5,'回补'),colorff00ff;
DRAWTEXT(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(Var12>Var13,3) AND REF(LOW,1)=LLV
(LOW,120) AND CLOSE>OPEN,LOW-0.2,'●'),coloryellow;
DRAWTEXT(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(Var12>Var13,3) AND REF(LOW,1)=LLV
(LOW,120) AND CLOSE>OPEN,LOW+0.1,'低买'),coloryellow;
DRAWTEXT(REF(Var22,1)>Var22 AND REF(Var22,1)>100 AND CLOSE>REF
(CLOSE,1),HIGH+0.2,'●'),colorffff00;
DRAWTEXT(REF(Var22,1)>Var22 AND REF(Var22,1)>100 AND CLOSE>REF(CLOSE,1),HIGH+0.8,'短
出'),colorffff00;
DRAWTEXT(CROSS(84,Var1A),HIGH+0.2,'●'),colorgreen;
DRAWTEXT(CROSS(84,Var1A),HIGH+0.9,'高出1'),colorgreen;
DRAWTEXT(FILTER(Var1D>REF(Var1D,1) AND Var1E>REF(Var1E,1),5),HIGH+0.2,'●'),color00ff00;
DRAWTEXT(FILTER(Var1D>REF(Var1D,1) AND Var1E>REF(Var1E,1),5),HIGH+0.8,'高出
2'),color00ff00;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
RSr:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
Kr:=SMA(RSr,3,1),colorred;
Dr:=SMA(Kr,3,1),colorblue;
km:=(LOW)+k/100*((hhv(high,13)-llv(low,13))),;
dm:sma(km,3,1),COLORyellow;
MU:HHV(DM,3),COLORff00ff;
kn:=low+kr/100*((hhv(high,55)-llv(low,55))) ,;
dn:sma(kn,3,1),COLORred;
MV:HHV(DN,3),COLORffcc66;
xg:=cross(kr,dr) and km>dm and dr<34 and dm<15 and cross(km,dm),;
DRAWTEXT(xg>0 and ref(xg,3)=0 and ref(xg,4)=0 and ref(xg,5)=0 and ref(xg,6)=0
,low*0.995,'★'),colorred;
DRAWTEXT(xg>0 and ref(xg,3)=0 and ref(xg,4)=0 and ref(xg,5)=0 and ref(xg,6)=0
,low*1.05,'拉升'),colorred;

通达信超级波段幻影主图指标公式

 

相关文章