在线检测未来函数

同花顺涨停风景线指标公式

来源:Internet,编辑:股旁网,2015-07-05

STICKLINE(C>0,90,95,10,0),COLOR408000;
STICKLINE(C>0,10,5,10,0),COLOR408000;
HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(HDY>90,100,98,2,1),colorligreen;
STICKLINE(HDY>95,100,98,2,0),colorgreen;
STICKLINE(HDY<10,0,2,2,1),colorlired;
STICKLINE(HDY<5,0,2,2,0),colorred;
STICKLINE(C>0,90,10,10,0),COLOR000000;
风险值:HDY,colorcyan,LINETHICK2;
超高位区:=风险值>=95,colorgreen,NODRAW;
高位区:=风险值<95 AND 风险值>90,colorligreen,NODRAW;
低位区:=风险值<10 AND 风险值>5,colorlired,NODRAW;
超低位区:=风险值<=5,colorgreen,NODRAW;
背离:IF(C<REF(C,1) AND 风险值>REF(风险值,1) AND 风险值<15,1,0),colormagenta,NODRAW;
STICKLINE(底背离,0,-2,2,0),colormagenta;
顶背离:IF(C>REF(C,1) AND 风险值<REF(风险值,1) AND 风险值>85,1,0),colorblue,NODRAW;
STICKLINE(顶背离,100,102,2,0),colorblue;
A:=风险值/REF(风险值,1)-1;
B:=风险值/REF(风险值,2)-1;
高位变盘:A>=-0.035 AND A<=0.035 AND 风险值>50,NODRAW;
STICKLINE(高位变盘,50,52,2,0),colorred;
低位变盘:A>=-0.035 AND A<=0.035 AND 风险值<50,NODRAW;
STICKLINE(低位变盘,50,48,2,0),colorgreen;
危险:=高位变盘 AND C<REF(C,1);
STICKLINE(危险,52,53,1.6,0),colormagenta;
STICKLINE(危险,53,54,1.2,0),colormagenta;
STICKLINE(危险,54,55,0.8,0),colormagenta;
STICKLINE(危险,55,56,0.4,0),colormagenta;
STICKLINE(危险,56,57,0.2,0),colormagenta;
STICKLINE(危险,57,58,0.05,0),colormagenta;
A1:=CROSS(风险值,20) AND CROSS(风险值,35);
A2:=CROSS(风险值,35) AND CROSS(风险值,50);
A3:=CROSS(风险值,50) AND CROSS(风险值,65);
A4:=CROSS(风险值,65) AND CROSS(风险值,80);
急拉:=A1 OR A2 OR A3 OR A4;
DRAWTEXT(急拉,风险值,'↑急拉,注意'),colorred;
A5:=CROSS(20,风险值) AND CROSS(35,风险值);
A6:=CROSS(35,风险值) AND CROSS(50,风险值);
A7:=CROSS(50,风险值) AND CROSS(65,风险值);
A8:=CROSS(65,风险值) AND CROSS(80,风险值);
重挫:=A5 OR A6 OR A7 OR A8;
DRAWTEXT(重挫,风险值,'↓重挫,注意'),coloryellow;
风险线:80,colorred;
65线:65,colorwhite,DOTLINE;
中轴线:50,colorwhite,DOTLINE;
35线:35,colorwhite,DOTLINE;
安全线:20,colorgreen;
DRAWTEXT(ISLASTBAR,100,'超高位区'),colormagenta;
DRAWTEXT(ISLASTBAR,95,'高 位 区'),colorlimagenta;
DRAWTEXT(ISLASTBAR,88,'高缓冲区'),colorlired;
DRAWTEXT(ISLASTBAR,82.5,'80风险线'),colorred;
DRAWTEXT(ISLASTBAR,52.5,'50中轴线'),colorwhite;
DRAWTEXT(ISLASTBAR,22.5,'20安全线'),colorgreen;
DRAWTEXT(ISLASTBAR,10,'低 位 区'),colorligreen;
DRAWTEXT(ISLASTBAR,5,'超低位区'),colorliblue;
DRAWTEXT(ISLASTBAR,18,'低缓冲区'),colorblue;

同花顺涨停风景线指标公式

 

相关文章