在线检测未来函数

通达信MACD低位金叉买入指标公式

来源:Internet,编辑:股旁网,2015-07-05

DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,27);
DEA1:=EMA(DIFF1,9);
MACD:=2*(DIFF1-DEA1),STICK;
DIFF:DIFF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
强度:IF(DIFF>=DEA,DIFF,DRAWNULL),COLORRED;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,-0.1,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA*1.04,13) ;
DRAWTEXT(二次金叉,-0.1,' 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,POINTDOT;
DRAWTEXT(底背离,0.1,'底背离'),COLORMAGENTA;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORLIBLUE;
DRAWTEXT(顶背离,DIFF,'顶背离'),COLORLIBLUE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3.2,0),COLORB20000;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.7,0),COLOREC0000;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.1,0),COLORFF4600;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.5,0),COLORFF6300;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLORFF8B00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.3,0),COLORFFAB00;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.2,0),COLOR000055;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.7,0),COLOR000077;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.1,0),COLOR000099;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.5,0),COLOR0000BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLOR0000DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.3,0),COLOR0000FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.2,0),COLOR555555;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.7,0),COLOR777777;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.1,0),COLOR999999;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.5,0),COLORBBBBBB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.9,0),COLORDDDDDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.3,0),COLORFFFFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.2,0),COLORB20000;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.7,0),COLOREC0000;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.1,0),COLORFF4600;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.5,0),COLORFF6300;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.9,0),COLORFF8B00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.3,0),COLORFFAB00;
STICKLINE(MACD>=0 OR MACD<=0,0,0,50,2),COLORWHITE;
DRAWICON(低位金叉=1,DEA*0.9978-1,9);
DRAWICON(低位金叉=1,DEA*0.9978-2,11);
DRAWICON(低位金叉=1,DEA*0.9978-3,13);

通达信MACD低位金叉买入指标公式

 

相关文章