在线检测未来函数

通达信周旋指标公式

来源:Internet,编辑:股旁网,2015-07-06

M1:=3;
换手率: VOL/CAPITAL*100, ,COLORWHITE;
成交〖万手〗: VOL/10000, , COLOR00ccff;
Var2:=MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1)));
Var3:=IF(HIGH+LOW<=REF(HIGH,1)+REF(LOW,1),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
Var4:=IF(HIGH+LOW>=REF(HIGH,1)+REF(LOW,1),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
Var5:=SUM(Var3,13)/(SUM(Var3,13)+SUM(Var4,13));
Var6:=SUM(Var4,13)/(SUM(Var4,13)+SUM(Var3,13));
ADDI: (Var5-Var6)*100, COLORSTICK;
DI: SMA(ADDI,30,10), , COLORYELLOW;
AD: MA(DI,M1), , COLORMAGENTA;
Var7:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
Var8:=ZIG(3,5)< REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
STICKLINE(Var7=1,-10,0,8,0), , COLORRED;
STICKLINE(Var8=1,10,0,8,0), , COLORCYAN;
Var9:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VarA:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VarB:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VarC:=VarA< REF(VarB,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VarD:=(HIGH+LOW+CLOSE)/3;
VarE:=(VarD-MA(VarD,14))/(0.015*AVEDEV(VarD,14));
VarF:=(VarD-MA(VarD,70))/(0.015*AVEDEV(VarD,70));
Var10:=IF(VarE>=150 AND VarE<200 AND VarF>=150 AND VarF<200,10,0);
Var11:=IF(VarE<=-150 AND VarE>-200 AND VarF<=-150 AND VarF>-200,-10,Var10);
Var12:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var13:=100-ABS(Var12);
Var14:=IF(Var13<90,Var13,100);
Var15:=IF(Var9>0,Var9,0);
Var16:=IF(VarF>=200 AND VarE>=150,15,IF(VarF<=-200 AND VarE<=-150,-15,Var11))+60;
Var17:=Var15>48 AND Var16>60 AND Var14<100;
DRAWTEXT(VarC AND COUNT(VarC,1)=1,20,'$'), , COLORYELLOW;
DRAWTEXT(Var17 AND COUNT(Var17,1)=1,40,'$'), , COLORGREEN;
Var18:=SUM(MAX(0,HIGH-REF((HIGH+LOW+CLOSE)/3,1)),26)/SUM(MAX(0,REF((HIGH+LOW+CLOSE)/3,1)-LOW),26)*100;
DRAWTEXT(Var18>250 AND Var8=1,-20,'风险!'), , COLORRED;
Var19:=IF((CLOSE+OPEN+HIGH+LOW)/4-SMA((CLOSE+OPEN+HIGH+LOW)/4,150,1)<0,CAPITAL/VOL,0);
Var1A:=IF(Var19>300,Var19,0);
STICKLINE(Var1A>600,-40,-20,1,0), , COLORMAGENTA;
Var1B:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var1C:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var1D:=SMA(Var1C,13,8);
Var1E:=SMA(Var1B,21,8);
趋势: (SMA(Var1D,13,8)), , COLORBLUE;
盘整: STICKLINE(趋势-Var1E<-65,0,5,15,1), , COLORYELLOW;
Var1F:=WINNER((CLOSE+OPEN+HIGH+LOW)/4)*1000;
圈: IF(Var1F>180,0,-10),COLORGREEN;

通达信周旋指标公式

 

相关文章