在线检测未来函数

通达信乐及生悲指标公式

来源:Internet,编辑:股旁网,2015-07-06

阶段卖出线:3.1, COLORWHITE;
卖出线:3.5,COLORMAGENTA;
动力:EMA((CLOSE-LLV(L,10))/(HHV(H,25)-LLV(L,10))*4,4),COLORGREEN;
Var1:=(CLOSE-MA(C,6))/MA(C,6)*100;
Var2:=(CLOSE-MA(C,12))/MA(C,12)*100;
Var3:=(CLOSE-MA(C,24))/MA(C,24)*100;
Var4:=(Var1+2*Var2+3*Var3)/6;
Var5:=MA(Var4,3);
Var6:=(CLOSE-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
Var7:=SMA(Var6,3,1);
Var8:=SMA(Var7,3,1);
Var9:=3*Var7-2*Var8;
关注:IF(CROSS(Var9,Var8) AND COUNT(Var5<-9,2)>=1,1,0),COLORCYAN;
VarA:=REF(L,1)*0.9;
VarB:=LOW*0.9;
VarC:=(VarB*VOL+VarA*(CAPITAL-VOL))/CAPITAL;
VarD:=EMA(VarC,30);
VarE:=CLOSE-REF(C,1);
VarF:=MAX(VarE,0);
Var10:=ABS(VarE);
Var11:=SMA(VarF,7,1)/SMA(Var10,7,1)*100;
Var12:=SMA(VarF,13,1)/SMA(Var10,13,1)*100;
Var13:=SMA(MAX(VarE,0),6,1)/SMA(ABS(VarE),6,1)*100;
Var14:=-200*(HHV(H,60)-CLOSE)/(HHV(H,60)-LLV(L,60))+100;
Var15:=(CLOSE-LLV(L,15))/(HHV(H,15)-LLV(L,15))*100;
Var16:=SMA((SMA(Var15,4,1)-50)*2,3,1);
Var17:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var18:=SMA(Var17,4,1);
Var19:=SMA(Var18,3,1);
Var1A:=(HHV(H,30)-CLOSE)/CLOSE*100;
Var1B:=Var13<=25 AND Var14<-95 AND Var1A>20 AND Var16<-30 AND Var19<30 AND (VarD-CLOSE)>=-0.25 AND Var11<22 AND Var12<28;
↑导弹:STICKLINE(Var1B,0.1,1.5,2,0),COLORRED;
Var1C:="RSI.RSI1">78 AND "ROC.ROC"< REF("ROC.ROC",1) or "BIAS.BIAS3">20;
高:STICKLINE(Var1C>0.2,0,305,0,0),COLORYELLOW;
Var1D:=SMA(V,5,1);
Var1E:=(Var1D-LLV(Var1D,10))/(HHV(Var1D,10)-LLV(Var1D,10))*100;
Var1F:=SMA(Var1E,3,1);
Var20:=100-Var1F;
Var21:=REF(Var20,1)>REF(Var20,2) AND Var20<34;
Var22:=CLOSE-LLV(L,34)/(HHV(H,34)-LLV(L,34))*100;
Var23:=FILTER(Var21,3);
Var24:=SMA(Var22,3,1);
走:STICKLINE(Var23 AND Var24>60,3.5,0,0,0),COLORMAGENTA;
Var25:=CROSS(MA(INDEXV,31),MA(INDEXV,2));
Var26:=LLV(INDEXL,60);
Var27:=IF(INDEXC>Var26*1.15,Var25,0);
大盘顶:STICKLINE(Var27>0.2,3.75,3.6,50,0),COLORRED;
Var28:=CROSS(MA(INDEXV,14),MA(INDEXV,51));
Var29:=HHV(INDEXH,125);
Var2A:=IF(INDEXC< Var29,Var28,0);
Var2B:=(INDEXC-REF(INDEXC,26))/REF(INDEXC,26)*100;
大盘底:STICKLINE(Var2B<-9.5 AND Var2A>0.2,0.3,0,50,0),COLORGREEN;
STICKLINE(CLOSE>(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,0,0,10,0),COLORRED;
DRAWICON(CROSS(Var1C,0.9) AND Var1C,0.5,2);
DRAWICON(Var23 AND Var24>60,0.5,2),COLORMAGENTA;
DRAWICON(动力>阶段卖出线,阶段卖出线,1);

通达信乐及生悲指标公式

 

相关文章