在线检测未来函数

大智慧红色牛市波段指标公式

来源:Internet,编辑:股旁网,2015-07-09

{使用说明:第一个:60分钟中期线上穿长期线,同时周线的中期线小于长期线。第二个:60分钟中期线上穿长期线,同时周线的中期线大于长期线,并且月线的中期线小于长期线。第三个:60分钟中期线上穿长期线,同时周线的中期线大于长期线,并且月线的中期线大于长期线。}

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
短期线:B+100,COLORWhite,LINETHICK2;
中期线:D+100,COLORYELLOW,LINETHICK3;
牛市线:A+100,COLOR9900FF,LINETHICK5;
见顶:=((REF(中期线,1)>85
AND REF(短期线,1)>85 AND REF(牛市线,1)>65) AND CROSS(牛市线,短期线));
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND
(REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 牛市线>60 AND 短期线<83.5
AND
短期线<中期线 AND 短期线<牛市线+4,COLORFF00FF;顶部:=FILTER(顶部区域,4);
STICKLINE(
顶部,99,103,20,1 ),COLORFF00FF,LINETHICK5;
底部区域:(牛市线<12 AND 中期线<8 AND
(短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR
短期线>REF(短期线,1)))
OR (牛市线<8 AND 中期线<7 AND 短期线<15 AND
短期线>REF(短期线,1)) OR (牛市线<10 AND 中期线<7 AND 短期线<1)
,COLORGREEN;
STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN,LINETHICK3;
低位金叉:50*(牛市线<15
AND REF(牛市线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,牛市线) AND
短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND
(中期线>=牛市线 OR REF( 短期线,1)<1 )),COLORRED,LINETHICK3;
STICKLINE( 低位金叉,0,5,11,0
),COLORRED;80,COLOR996699;20,COLORGREEN;10,COLORCC6633,LINETHICK3;
90,COLOR9966FF,LINETHICK3;

大智慧红色牛市波段指标公式

 

相关文章