在线检测未来函数

通达信多空庄线主图指标公式

来源:Internet,编辑:股旁网,2015-07-10

AAA:=CONST(HHV(H,90));
DRAWTEXT(C AND CURRBARSCOUNT=80 ,AAA, 38),COLORMAGENTA;
SJTJ:=DATE<1590301;
DK:= SJTJ AND H>REF(HHV(HIGH,7),1);
KK:= SJTJ AND L<REF(LLV(LOW,7),1);
DK1:=BARSLAST(DK);
KK1:=BARSLAST(KK);
DK2:=BARSLAST(CROSS(KK1,DK1));
KK2:=BARSLAST(CROSS(DK1,KK1));
HS:=DK2<KK2;
LS:=KK2<DK2;
W2:=OPEN-CLOSE;
HT:=IF(OPEN>CLOSE,OPEN,CLOSE);
LT:=IF(OPEN<CLOSE,OPEN,CLOSE);
STICKLINE(W2>0 AND HS,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(W2>0 AND HS,OPEN,H,0.0,0),COLORRED;
STICKLINE(W2>0 AND HS,C,L,0.0,0),COLORRED;
STICKLINE(W2<=0 AND HS,OPEN,CLOSE,2,1),COLORRED;
STICKLINE(W2<=0 AND HS,O,L,0.0,0),COLORRED;
STICKLINE(W2<=0 AND HS,C,H,0.0,0),COLORRED;
STICKLINE(W2>0 AND LS,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(W2>0 AND LS,OPEN,H,0.0,0),COLORGREEN;
STICKLINE(W2>0 AND LS,C,L,0.0,0),COLORGREEN;
STICKLINE(W2<=0 AND LS,OPEN,CLOSE,2,1),COLORGREEN;
STICKLINE(W2<=0 AND LS,C,H,0.0,0),COLORGREEN;
STICKLINE(W2<=0 AND LS,O,L,0.0,0),COLORGREEN;
DRAWTEXT(HS=1 AND REF(LS,1),LOW*0.997,39),COLORYELLOW;
DRAWTEXT(LS=1 AND REF(HS,1),H*1.003,40),COLORYELLOW;
YZX:=IF(HS,REF(LLV(LOW,7),1),REF(HHV(HIGH,7),1));
多方庄线:IF(HS,YZX,DRAWNULL),LINETHICK2,COLORRED;
空方庄线:IF(LS,YZX,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWNUMBER(ISLASTBAR ,YZX,YZX),COLORYELLOW;

通达信多空庄线主图指标公式

 

相关文章