在线检测未来函数

飞狐图穷匕现指标公式

来源:Internet,编辑:股旁网,2015-07-13

QVAR2:=IF((HIGH+LOW<=REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
QVAR3:=IF((HIGH+LOW>=REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
QVAR4:=(SUM(QVAR2,13))/(SUM(QVAR2,13)+SUM(QVAR3,13));
QVAR5:=(SUM(QVAR3,13))/(SUM(QVAR3,13)+SUM(QVAR2,13));
QVAR9:=100-(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
QVARA:=100-(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
QVARB:=(QVAR9<REF(QVARA,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8) ;
QVAR1D:=SMA(QVAR1A,21,8);
杀机乍现:SMA(QVAR1C,13,8),Coloryellow,Linethick2;
见礼台杀机乍现:-QVAR1D<(-65),Stick,COLORMAGENTA,Linethick5;
QVAR1E:=(CLOSE+OPEN+HIGH+LOW)/(4);
AA:=QVARB AND (COUNT(QVARB,1)=1) AND (杀机乍现<80);
VAR1:=IF(((EMA(CLOSE,5))/(EMA(EMA(CLOSE,9),16))<=0.85000002) AND ((CLOSE)/(REF(CLOSE,1))>0.90499997) AND ((CLOSE)/(REF(CLOSE,1))<1.05) AND (((VOL)/(CAPITAL))*(100)<5),50,0);
图穷匕现:MA((((-100))*(HHV(HIGH,34)-CLOSE))/(HHV(HIGH,34)-LLV(LOW,34))+100,5);
VAR3:=(((-100))*(HHV(HIGH,50)-CLOSE))/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR4:=(((-100))*(HHV(HIGH,70)-CLOSE))/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR5:=(((CLOSE-MA(CLOSE,34))/(MA(CLOSE,34)))*(100)+10)*(5);
VAR6:=(((CLOSE-MA(CLOSE,50))/(MA(CLOSE,50)))*(100)+10)*(5);
VAR7:=(((CLOSE-MA(CLOSE,70))/(MA(CLOSE,70)))*(100)+10)*(5);
VAR8:=(图穷匕现+VAR3+VAR4+VAR5+VAR6+VAR7)/(6);
VAR9:=EMA(VAR8,3);
VARA:=ABS(VAR5-VAR7);
VARB:=(VAR8+VARA)/(2);
VARC:=(-1);
VARD:=VARC+VARB;
VARE:=IF((VAR1>0) AND (VARD<0),200,0);
VARF:=IF((VARB<0) AND (CLOSE=LLV(CLOSE,5)) AND ((CLOSE)/(REF(CLOSE,1))>0.90499997) AND ((CLOSE)/(REF(CLOSE,1))<1.05) AND (((VOL)/(CAPITAL))*(100)<5),(-50),0);
VAR10:=IF((VARD<0) AND (VARF=(-50)),100,0);
VAR11:=(REF(CLOSE,2))*(0.86500001);
VAR12:=(REF(CLOSE,13))*(0.77200001);
VAR13:=MIN(VAR11,VAR12);
VAR14:=((100)*(VOL))/(CAPITAL);
VAR15:=IF(((CLOSE-VAR13)/(CLOSE)<0.02999999) AND ((SUM(VAR14,5))/(5)<1.8),1,0);
VAR16:=IF((VAR15>0) AND ((VARF<0) or (VAR1>0)),100,0);
VAR17:=((VARE>0) AND (VAR10>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR15>0)) AND ((VARF<0) or (VAR1>0));
VAR18:=((VARE>0) AND (VAR10>0) AND ((SUM(((VOL)/(CAPITAL))*(100),5))/(5)<1) or (VAR15>0) AND ((REF(CLOSE,1))/(REF(CLOSE,2))>0.90200001));
VAR19:=(VAR17 or VAR18);
VAR1A:=(VAR16 or VAR19);
VAR1B:=VAR16;
VAR1C:=MA(CLOSE,80)-(MA(CLOSE,10))/(3);
VAR1D:=IF((VAR1A>0),87,0);
VAR1E:=IF((VAR1B>0),91,0);
VAR1F:=IF((VAR16>0) AND (CLOSE<VAR1C),97,0);
VAR20:=MAX(MAX(VAR1F,VAR1D),VAR1E);
VAR21:=MA(CLOSE,80)-(MA(CLOSE,13))/(3);
VAR22:=MA((CLOSE-VAR21)/(VAR21),1);
VAR23:=(EMA(VAR22,12))*(0.69999998);
VAR24:=EMA(VAR22,3);
VAR25:=IF((LLV(VAR24-VAR23,12)>0),0,(-30));
15;
85;
FILTER((COUNT((VAR25<(-20)),3)=3),34)colorblack;
FILTER((VAR1D>80) AND (VAR1E>90) AND (VAR1F>90) AND (VAR20>90),13)colorblack;;
b:=((c+h+o+l+(c+o+l+h)/4+(o+C)/2+(l+h)/2)/7+(HIGH+LOW+CLOSE*2)/4)/2;
RSV:=(b-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV,3,1)*1.18;
D:=SMA(K,3,1);
STICKLINE(k>d,k,d,0.8,1),COLORred,Linethick5;
STICKLINE(k<d,d,k,0.8,1),colorgreen;
PARTLINE(k-d>=0,k),COLORred;
PARTLINE(k-d<=0,k),colorgreen;
drawIcon(Cross(杀机乍现,图穷匕现),图穷匕现,1);

飞狐图穷匕现指标公式

 

相关文章