在线检测未来函数

大智慧资金流向分析指标公式

来源:Internet,编辑:股旁网,2015-07-13

DRAWGBKLAST(v>1,STRIP(RGB(00,0,0),RGB(90,90,90),0));
{☆资金流向}
{//------【参数定义】}
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),LINETHICK0,COLORWHITE;
主力控盘系数:INTPART(ZZLKP),LINETHICK0,COLORCYAN;
资金流入强度:ZJLRQD,LINETHICK0,COLORRED;
市场筹码总量:INTPART(ZCMZL),LINETHICK0,COLORGREEN;
{//------【图解模板】}
{神秘黑洞}
FILLRGN(ZSHTL,0,REF(ZSHTL,1)>90 AND ZSHTL<90),COLOR9966FF;
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORaaaaaa;
{散户线}
PARTLINE(ZSHTL,C>0),POINTDOT,COLORYELLOW;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,7,0),COLORBLUE;
{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,7,0),COLORFFFFFF;
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,7,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,7,0),COLOR66FFCC;
{筹码总量}
PARTLINE(ZCMZL,C>0),COLORGREEN;
{筹码总量上升}
PARTLINE(ZCMZL,ZCMZL>REF(ZCMZL,1)),COLOR0066FF;
{增量资金}
DRAWTEXT(ZCMZL>REF(ZCMZL,1) AND SH8<REF(SH8,1) AND BARSTATUS=2,ZCMZL,'←增量资金');
{//------【解盘分析】}
TJTS:=BARSTATUS=2;
DRAWTEXT(TJTS and C>0,130,'资金流向分析 '),LINETHICK6,Coloryellow,ALIGN2;
DRAWTEXT(TJTS and C>0,130,' '+STKLABEL+' '+STKNAME+' '),LINETHICK6,ColorFFFF80,ALIGN2;
DRAWTEXT(TJTS and C>0,128,' '+ '走牛天数判断:'+' '+NUMTOSTRN( ZZNTS,0 )+' '),LINETHICK3,ColorFFFF80,ALIGN2;
{主力动向监控}
DRAWTEXT(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=1,110,'主力动向监控:主力增仓 '),COLORRED,ALIGN2;
DRAWTEXT(TJTS and ZCMZL>REF(ZCMZL,1) AND DKB=0,110,'主力动向监控:主力减仓 '),COLORMAGENTA,ALIGN2;
DRAWTEXT(TJTS and ZCMZL=REF(ZCMZL,1),110,'主力动向监控:多空平衡 '),COLORGRAY,ALIGN2;
DRAWTEXT(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=1,110,'主力动向监控:主力回补'),COLORFF9933,ALIGN2;
DRAWTEXT(TJTS and ZCMZL<REF(ZCMZL,1) AND DKB=0,110,'主力动向监控:主力出逃'),COLORGREEN,ALIGN2;
{特别信号提示}
DRAWTEXT(TJTS and ZSHTL>90,100,'特别信号提示:筑底散兵坑 '),COLOR66FFCC,ALIGN2;
DRAWTEXT(TJTS and ZZLKP>75,100,'特别信号提示:铸顶风险区 '),COLORCYAN,ALIGN2;
DRAWTEXT(TJTS and CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越主力 '),COLORRED,ALIGN2;
DRAWTEXT(TJTS and CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越主力 '),COLORYELLOW,ALIGN2;
DRAWTEXT(TJTS and CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:穿越散户 '),COLORGREEN,ALIGN2;
DRAWTEXT(TJTS and CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1),100,'特别信号提示:全盘穿越 '),COLOR3399FF,ALIGN2;

大智慧资金流向分析指标公式

 

相关文章