在线检测未来函数

通达信鹏腾2009版主图及选股指标公式

来源:Internet,编辑:股旁网,2015-07-20

M5:MA(C,5);
M10:MA(C,10);
M20:MA(C,20);
HH:=IF(BETWEEN(DATE,1150601,1150630),H,-999);
T:=HHVBARS(HH,0);
TT:=BARSLAST(L=LLV(L,T+1));
T1:=BARSLAST(CURRBARSCOUNT=CONST(TT)+1);
XL:=REFX(L,BARSNEXT(T1=0));
高位价:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,HH,ISLASTBAR,REF(HH,T),0),COLORYELLOW;
NOTEXT1:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,(HH-XL)*0.382+XL,ISLASTBAR,REF((HH-XL)*0.382+XL,T),0),DOTLINE,COLORGREEN;
大盘破日:BARSLAST(DATE=1150701)+1 NODRAW;
个股破日:BARSLAST(CROSS(NOTEXT1,C))+1 NODRAW;
TJ1:=个股破日<大盘破日 AND COUNT(CROSS(C,NOTEXT1),大盘破日)=1 AND CROSS(C,NOTEXT1);
TJ2:=COUNT(CROSS(NOTEXT1,C),个股破日)=1;
XG:=TJ1 AND TJ2;
DRAWICON(XG,L*0.98,1);
STICKLINE(DATE=1150701,C,O,2,0),COLORGREEN;
STICKLINE(DATE=1150701,H,L,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=CONST(个股破日),C,O,2,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=CONST(个股破日),H,L,0,0),COLORYELLOW;
低位价:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,XL,ISLASTBAR,REF(L,T1),0),COLORRED;
DRAWTEXT(CURRBARSCOUNT=CONST(T)+1,NOTEXT1*1.04,VARCAT(VARCAT('第一阻力:',VAR2STR(NOTEXT1,2)),'元')),COLORGREEN;

{
选股公式:

HH:=IF(BETWEEN(DATE,1150601,1150630),H,-999);
T:=HHVBARS(HH,0);
TT:=BARSLAST(L=LLV(L,T+1));
T1:=BARSLAST(CURRBARSCOUNT=CONST(TT)+1);
XL:=REFX(L,BARSNEXT(T1=0));
NOTEXT1:=DRAWLINE(CURRBARSCOUNT=CONST(T)+1,(HH-XL)*0.382+XL,ISLASTBAR,REF((HH-XL)*0.382+XL,T),0);
大盘破日:=BARSLAST(DATE=1150701)+1;
个股破日:=BARSLAST(CROSS(NOTEXT1,C))+1;
TJ1:=个股破日<大盘破日 AND COUNT(CROSS(C,NOTEXT1),大盘破日)=1 AND CROSS(C,NOTEXT1);
TJ2:=COUNT(CROSS(NOTEXT1,C),个股破日)=1;
XG:TJ1 AND TJ2;
}

通达信鹏腾2009版主图及选股指标公式

 

相关文章