在线检测未来函数

通达信DMI优化指标公式

来源:Internet,编辑:股旁网,2015-07-21

N:=14;
MM:=4;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR,LINETHICK1,COLORWHITE;
MDI: DMM*100/MTR,LINETHICK1,COLORYELLOW;
IF(PDI>=MDI, PDI,DRAWNULL),LINETHICK2,COLORRED;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM),COLORMAGENTA, ;
ADXX:= EXPMEMA( (MDI-PDI)/(MDI+PDI)*100,MM),COLORMAGENTA, ;
ADXXX:REVERSE(ADXX),COLORMAGENTA, ;
ADXR:=EXPMEMA(ADX,MM),COLORGREEN,DOTLINE;
ADXRR:=EXPMEMA(ADXX,MM),COLORGREEN,DOTLINE;
ADXRRR:REVERSE(ADXRR),COLORGREEN, ;
DRAWBAND(REVERSE(ADXX),RGB(250,150,0),REVERSE(ADXRR),RGB(0,150,250));

通达信DMI优化指标公式

 

相关文章