在线检测未来函数

通达信转折线指标公式

来源:Internet,编辑:股旁网,2015-07-22

X1:=(CLOSE+LOW+HIGH)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
VAR2:=EMA(EMA(X1,1),13);
VAR3:=EMA(VAR2,21);
XCLOSE:=EMA((OPEN+HIGH+LOW+CLOSE)/4,3);
XOPEN:=EMA((REF(OPEN,1)+REF(XCLOSE,1))/2,3);
TEMPG:=MAX(HIGH,XOPEN);
XHIGH:=EMA(MAX(TEMPG,XCLOSE),3);
TEMP:=MIN(LOW,XOPEN);
XLOW:=EMA(MIN(TEMP,XCLOSE),3);
O1:=IF(XOPEN<XCLOSE,XOPEN,XCLOSE);
C1:=IF(XOPEN<XCLOSE,XCLOSE,XOPEN);
{K线}
STICKLINE(XOPEN>=XCLOSE,XHIGH,XLOW,0,0 ),COLORRED;
STICKLINE(XOPEN>=XCLOSE,C1,O1,4,0 ),COLOR000055;
STICKLINE(XOPEN>=XCLOSE,C1,O1,3,0 ),COLOR000077;
STICKLINE(XOPEN>=XCLOSE,C1,O1,2.5,0 ),COLOR000099;
STICKLINE(XOPEN>=XCLOSE,C1,O1,1.5,0 ),COLOR0000BB;
STICKLINE(XOPEN>=XCLOSE,C1,O1,0.9,0 ),COLOR0000DD;
STICKLINE(XOPEN>=XCLOSE,C1,O1,0.3,0 ),COLOR0000FF;
STICKLINE(XOPEN<XCLOSE,XHIGH,XLOW,0,0 ),COLORCYAN;
STICKLINE(XOPEN<XCLOSE,C1,O1,4,0 ),COLOR990000;
STICKLINE(XOPEN<XCLOSE,C1,O1,3,0 ),COLORCC0000;
STICKLINE(XOPEN<XCLOSE,C1,O1,2.5,0 ),COLORFF4400;
STICKLINE(XOPEN<XCLOSE,C1,O1,1.5,0 ),COLORFF8800;
STICKLINE(XOPEN<XCLOSE,C1,O1,0.9,0 ),COLORFFCC00;
STICKLINE(XOPEN<XCLOSE,C1,O1,0.3,0 ),COLORCYAN;
AC:=CLOSE;
转强:=MA(HIGH,6);
转弱:=MA(LOW,6);
B:=CLOSE*0;
转折线:IF(B=-1,MA(HIGH,6),MA(LOW,6)),LINETHICK2,COLORFFFFFF;

通达信转折线指标公式

 

相关文章